cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Announcements: Closed for comments in Student View

Jump to solution

When I create an Announcement it appears open for comments in my teacher view.  When I switch to student view it is closed for comments.  I'm not seeing a way to change the setting.  Did I miss something?

1 Solution

Accepted Solutions

Hi, sschedler@messiah.edu‌, I just did a quick test. If the ability to comment on announcements is disabled in the Settings area of the course, the checkbox to allow replies will not appear in the announcement interface, as that option would be disabled globally. If you'd like your students to be able to reply to your announcements, click on the Settings tab for the course, then on Course Settings (the tab at the top), and then scroll down to more options. Clicking more options reveals the ability to enable or disable replies to announcements; that checkbox is enabled by default, meaning that replies are disabled by default. Once you've enabled replies by de-selecting the box, you can make the decision on each announcement case-by-case.

This resource provides the visuals: How do I disable announcement replies for an entire course? 

View solution in original post

7 Replies
Community Coach
Community Coach

Hi sschedler@messiah.edu.  When creating an announcement, there is a checkbox at the bottom of the announcement options that indicates whether or not students can reply to the announcement (see information here, How do I add an announcement in a course?).  Does chancing this impact what you are seeing from the instructor/student view?  

All the best!

Eric,

Thanks for the quick reply.  I had been well familiar with that checkbox for many years.  However, I'm not seeing it now:Screenshot

That is strange sschedler@messiah.edu Have you tried in a different browser or tried updating your current one?  I just check in both Chrome and Firefox on my end and still have the checkbox you are missing.  If your browser is updated and the issue still exists, you might submit a support ticket so the folks in Canvas Support can look into what may be happening and if the problem is wide spread.  However, I would be curious to see if Firefox or Chrome works for you.

I was in Safari.  I opened in Chrome.  Same thing.  The box is missing.  I'll look at making a ticket.  

Hi, sschedler@messiah.edu‌, I just did a quick test. If the ability to comment on announcements is disabled in the Settings area of the course, the checkbox to allow replies will not appear in the announcement interface, as that option would be disabled globally. If you'd like your students to be able to reply to your announcements, click on the Settings tab for the course, then on Course Settings (the tab at the top), and then scroll down to more options. Clicking more options reveals the ability to enable or disable replies to announcements; that checkbox is enabled by default, meaning that replies are disabled by default. Once you've enabled replies by de-selecting the box, you can make the decision on each announcement case-by-case.

This resource provides the visuals: How do I disable announcement replies for an entire course? 

View solution in original post

Yes!  That did it.  I thought it was something like that but did not see the tiny "more options" link at first glance. 

Thanks!

Glad that worked sschedler@messiah.edu  Thanks for bringing up the option of the global setting stefaniesanders  I didn't remember that option existing!