cancel
Showing results for 
Search instead for 
Did you mean: 
opetersen
Community Member

Assignment not showing up in "add to module" list?

Jump to solution

I am trying to add an assignment from my assignment page into a module. However, it won't show up when I click the plus icon and select "assignments" - it is just not in the list. I logged out and back in, unpublished and republished the assignment, refreshed the page, all with no luck. Any advice? 

28 Replies
wrose31
Surveyor

It is infuriating. It's a major problem and makes it impossible to actually use Modules reliably. If you create a few assignments and try to add them to a module, you MIGHT be able to do it or you might have to wait 5 minutes. Or you might have to wait an hour, who knows? 

cdollar
Surveyor II

I also have no prereq on the module and this happens to me all the time. Usually clearing my cache works but it did not this time. I logged out and back in, and it is still now working. VERY frustrating!!!

klkteacherboy
Surveyor

Happens to me all the time. Sometimes log off helps but not always. There are also times I go to the Assignment page to search for it & it is not showing up. But later will. I wish when you went to the page where you are looking to add it to a module there was an option to search so you could then go to it & add it. 

lmmurp2
Surveyor II

same issue. I've had to find the assignment in the assignment page, copy to, select the SAME course I built it in and select the module I want it to go to. It's a work around but NOT what I should have to do -- total time suck. I've tried logging in & out, waiting up to 30 min, but honestly, who can wait 30 minute neverless 24 hours as someone suggested? 

View solution in original post

0 Kudos

This is a problem for me as well. This is the first time I've run into it. In my case, I created an assignment then duplicated it 7 times, changing the title each time. When I go to add the assignment to a module, none of the assignments show up, including the original one. I'll try the work-arounds but so far, I haven't been able to figure it out.

I don't know how or why this post was marked as "Solution" when it clearly is not a solution to this problem.

Fyi, I learned from Canvas Support today that this is a known issue if you have "too many" assignments in your course. 

What *sometimes* works is to re-open the assignment, make a small change, and then save it.  Then look for the assignment using the Module "+" pulldown. 

That worked for me in one case several weeks ago, but not today.

If it doesn't work, Instructure has no solution except to suggest you do a workaround.  What you'll need to do is create a new assignment *from* the Modules page (so it shows up in the Module).   Then enter the text of the assignment.   If you've already created an assignment that you can't add from the Modules page, copy/paste the text from that assignment into the new one you created from the Module page.

 

gnoack
Navigator

The only time I've had this issue is when I have different parts of the same course open in multiple browser windows.  If I have the modules open in window 1 and the assignments page open in window 2, when I create new assignments (or discussions, or any resource) they aren't available to me in on the modules page in window 1 until I refresh the page.  The list of possible resources to add to a module is loaded when the module page loads in the browser, not when you click on the plus button to add a resource.  A quick reload of the module page in browser tab 1 fixes the issue. 

This may or may not be what is happening, but I thought I would mention it. 

What you describe can be a problem, but in general this is not the problem everyone else is having. I have Canvas open in a single tab. I can do a hard-reload, clear cookies, clear the cache, etc. and there be no effect on what shows up.  Canvas has told my university the problem is their servers are busy processing other work. There's nothing you can do to make their servers speed up.

View solution in original post

0 Kudos

Thanks, but to me having to reload the page is not "quick"! This is my problem. I know I will see the new content in list to add to the module after I refresh, but I don't want to have to refresh. 

sbridge
Adventurer

Having same issue.  Who has time to wait around for it finally show up?