cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Member

Browser does not meet minimum requirements for Canvas. Please help.

Jump to solution

Good morning. I received a message in CANVAS saying that my browser does not meet the minimum requirements for CANVAS. Please visit the  Canvas Community for a complete list of supported browsers.

I am not clear on what this means. Please explain.  Kai Perkins Kindergarten Teacher Leesylvania ES

Message says, your browser does not meet the minimum requirements for Canvas.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Community Team
Community Team

perkinkd@pwcs.edu Welcome to the Canvas Community!

The list of supported browsers is in What are the browser and computer requirements for Canvas? . You will need to compare the version of the browser (preferably Chrome or Firefox) you're currently using to access Canvas with those listed in the document and then update to a current version.

View solution in original post

0 Kudos
3 Replies
Highlighted
Community Team
Community Team

perkinkd@pwcs.edu Welcome to the Canvas Community!

The list of supported browsers is in What are the browser and computer requirements for Canvas? . You will need to compare the version of the browser (preferably Chrome or Firefox) you're currently using to access Canvas with those listed in the document and then update to a current version.

View solution in original post

0 Kudos
Highlighted

I don't understand compare the version of the browser you're currently using to access Canvas.

How do I do that?

Frustrated.

Kai Perkins

0 Kudos
Highlighted

perkinkd@pwcs.edu

How this is accomplished depends on which browser you're using. From your screenshot, it appears that you're on a Windows device, but I can't tell from the screenshot which browser that is.

Here are instructions for updating the commonly-used Chrome browser: Update Google Chrome - Google Chrome Help

0 Kudos
Labels