cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Surveyor

Canvas Google Apps LTI authorization failures

Jump to solution
  • UPDATE Jan 18, 2018  —Still broken. No word on a fix....
  • UPDATE Aug 8, 2017  —Canvas recognizes this is a bug and is working on a fix (Cases #01843701, #01865357, #02000557). Not sure how or where to get updates on their progress.
  • UPDATE Aug 4, 2017  —Still broken. Still no error message suggesting the user switch browsers or login to Chrome with another account. Still many confused users getting frustrated because Canvas doesn't work Smiley Sad.
  • UPDATE Apr 24, 2017 —Still broken. Not answered. Don't let the "Assumed Answered" label fool you.
  • UPDATE Apr 20, 2017 —Still broken. No movement to fix on Instructure's part. They say it's "working as designed." If so, their design that forces students to jump through more hoops (see comments below) to access course content is a bad one. The goal should be to minimize navigation efforts and maximize access to content. The Canvas Google Apps LTI fails in this criteria.

ORIGINAL ISSUE, AS IT STILL STANDS — The Canvas Google Apps LTI authorization is failing on me in Chrome in one course (not others), and observed with faculty. Anyone else? Workarounds?The chat with Instructure support helped determine that it worked in Firefox but not Chrome. They suspected it may have something to do with being logged into multiple accounts. His boss suggested that the Google Apps LTI might need to be re-setup (by our Admin). 

Here's a screencast of the issue: Canvas Google LTI failures - YouTube 


More troubleshooting:

  1. I cleared all Instructure and Canvas cookies,
  2. then logged out of all Google accounts in Chrome,
  3. then shut down and restarted Chrome.
  4. Then opened afflicted Canvas course (https://canvas.wisc.edu/courses/39891/pages/feb-3-rubrics-in-canvas)
  5. Still saw no Google content and was asked to Authorize. Authorization fails.

Note

  • works in Incognito mode in Chrome.
  • works in other Canvas courses in Chrome.
  • works in Firefox.

Final bit of troubleshooting:

  • it seems to definitely be the Canvas tool's issue. 
  • a manual Google Doc iFrame embed works fine in Chrome, in that course.
111 Replies
Highlighted
Community Member

Hi everyone--forgive me, I haven't had a chance to read through the entire thread, but before we hit the weekend I wanted to add the testing I've done. Here's what I've seen:

Almost all of my testing has been done with @gmail.com accounts because I wanted to be using accounts without a lot of technical baggage. I’m also using virtual machine snapshots created immediately after Chrome was installed (and the VM was created) so there’s no device-side user data whatsoever.


Here’s one test I did: https://iu.box.com/s/yo90n2fpgrxmsmmlewpxqsgnbpby60rl (you should be able to play this video in a browser, wouldn’t recommend downloading it)


1. I demo that I’m using a brand new, up-to-date version of Chrome. This is on a new, completely unused virtual machine. Cache and cookies are cleared, Chrome is reset.
2. 0:54 – in an incognito window I sign into scmctest1@gmail.com. I demonstrate that I haven’t authorized the Google Drive LTI to access that account yet.
3. 1:53 – I’ve reclosed the incognito window and reopened it. I log into Google with scmctest3@gmail.com and demonstrate that I haven’t authorized the Google Drive LTI to access that account yet.
4. 2:29 – I sign into Chrome with my scmctest1@gmail.com account.
5. 2:58 – I log into Canvas with scmctest3@gmail.com.
6. 3:25 – I demo that I don’t have any Approved Integrations listed for scmctest3@gmail.com in Canvas. I also don’t have Drive listed under Registered Services.
7. 3:40 – I attempt to create a new collaboration. I’m asked to authorize my account.
8. 3:45 – I click Authorize and am prompted to either select the scmctest1@gmail.com account that I logged in with at step 4 or click “Use another account”. I click “Use another account”, wanting to log in with scmctest3@gmail.com instead.
9. 3:55 – I enter scmctest3@gmail.com’s credentials and choose to allow Google to access the account.
10. 4:10 – I receive an “Authorization failed” error.
11. 4:18 – I show that as far as Canvas is concerned (via Settings), I’ve successfully authorized a Google account.
12. 4:28 – I show that as far as Google is concerned, I haven’t authorized any access for my scmctest1@gmail.com account.
13. 4:34 – I show that as far as Google is concerned, I’ve authorized LTI access for my scmctest3@gmail.com account.

TL;DR: The “Use another account” prompt does not work. Canvas Support has indicated that this is expected behavior.

Another: https://iu.box.com/s/8otz2fn82eyebamk700x0t567otv7eai
1. Same as above: brand new, up-to-date version of Chrome. New, unused VM.
2. 0:41 – I display the Google sign in screen to show that I’m not logged in.
3. 1:06 – I open an incognito window and log in with scmctest3@gmail.com. I show that I haven’t authorized any apps to access that account. I close the incognito window.
4. 1:38 – In a regular browsing window I log into Chrome with scmctest3@gmail.com.
5. 1:57 – I show that I don’t have any Approved Integrations listed Canvas-side.
6. 2:10 – I open Google Drive in a course and authorize my scmctest3@gmail.com account.
7. 2:35 – I receive an “Authorization failed” error. I attempt to authorize the account again and this time Google Drive loads as expected. Refreshing the page would have also worked.

According to Canvas Support, this is expected behavior, and could’ve been avoided if I’d logged into my account at google.com before trying to authorize it in Canvas. I did try this later (logging into Google first) and still ran into the auth error, and it was suggested that I add Google Drive as a Registered Service to work around it. That actually worked, but apparently shouldn't have given that the documentation indicates that you don't need to do it.

All that aside, I'm also hearing from students who are having to request access to docs that they were added to via Collaborations. They're actually added to groups in Canvas and their groups are added to the docs. All the docs were created the same way and the same groups are used, but the students have to request access to some of the docs and not others (in the same browser, in the same session). Has anyone else run into this? I haven't figured out what's causing it yet.

Highlighted

Hi emihunt@iu.edu

Thank you so much for going down that rabbit hole that you did! I hope that Instructure will begin to see what a problem this is, and put more resources towards fixing it (soon, please!).

In the mean time, I have been actually actively discouraging our 4000 instructors and 50k students from using any of the Canvas LTI tools or Google Collaborations because of the types of issues that you're seeing (which cause instructors, students, and support folks so many headaches!).

Instead of Collaborations, which open to a blank document, I distribute Google Doc worksheets with prompts via the Google Doc "/copy" trick. This trick prompts —with a single button — whoever clicks on the link to create a copy of the document (with prompts for them to answer) in the student's own Google Drive. I can assign this as a Group assignment if I want students to collaborate on it. They share back with me. It's not as nice and smooth as Collaborations could be, but much nicer than it currently is.

To do this, I just take the URL of an "Anyone with the link can view" doc, and replace the "/edit..." text with "/copy". For example: "https://docs.google.com/document/d/1Cx9EitFvsh-Vz3AQ1XY32cNdPvfniz814IPMIxXX2EQ/edit" becomes "https://docs.google.com/document/d/1Cx9EitFvsh-Vz3AQ1XY32cNdPvfniz814IPMIxXX2EQ/copy". Of course you can also use the link tool to change the text to "Active Teaching Lab Schedule".

Naturally, our preference would be for the Canvas tools to work, but since there's been no forward movement on these issues since the tool was released last January, I'm researching workarounds. 

Please keep sharing any more insights and workarounds you find! Thanks!

Highlighted

The Google LTI is the only LTI that I have had this difficulty with at this time, and we use many integrations.   We did have some problems when students went to a publisher's site to register for course material instead of going through Canvas to the publisher's site, but that has resolved itself with training.

Have you seen this type of problem with other integrations?

Highlighted
Surveyor

The two primary issues we're encountering with the integration so far this school year are:

1) Long processing delays when students have selected an item in their Drive via the Google Drive tab (assignment submission option in Canvas) and eventual failure to submit. Instructure has suggested this might be related to poor network capacity, so I've reached out to the affected teacher-users to inquire about typical connectivity in their classrooms and will be following up with support.

2) A few instances of Google Cloud Assignments being submitted by students only to reveal a capture error when the teacher attempts to view in Speedgrader. While this occurred to me and the adults I was working with on Friday morning, by afternoon submissions from later participants were being successfully captured and were visible in Speedgrader. This has been escalated to engineering support in Service Cloud.

251606_failed cloud capture.png

Highlighted
Adventurer II

In nearly all the cases of  Google Authorization failure, we have solved the issue by having students clear their cache. 

I was so happy to stumble across this post this morning!  I feel your pain regarding the Google LTI integration. It's our first full year of integration and I have teachers asking to go back to Google Classroom for the headaches they've been having! I was hoping to NOT have to go back to the Google Doc edit/copy URL changes. 

Our Language Arts teachers especially are asking to be able to show mark-ups on the submitted Google Doc, so the students can continue editing the same doc. It would be nice to be able to do this without the students sharing the document with the teacher. What's the point of the LMS then?

kblack@dom.edu‌, can you help us?

Highlighted

rislis@holmen.k12.wi.us, do your students use their own laptops or school-issued ones?

Highlighted

School issued Chromebooks. 1:1.

Highlighted

Thanks rislis@holmen.k12.wi.us! That's useful information! As far as I've seen, there haven't been significant issues for that subset of users. At UW-Madison we've got a lot less control (none) of what students use to access the content. I suspect the LTI tools were developed with your use case in mind, but were never really tested with what our situation is Smiley Sad.

Highlighted

And I can imagine professors never wanting to use it again, as they run into those Google LTI issues. 

Highlighted
Surveyor

Thank you for thoroughly documenting this issue john.martin@wisc.edu‌. I work at RMIT University, which uses Google Edu Apps with various restrictions, and having adopted Canvas this year (for wider scale roll out 2018) I've only just recently encountered this problem as well. I called Canvas support in October, and the person I spoke to did not seem well briefed in the issue - simply advising me to use another browser in future. I'll try asking our admins to reinstall the LTi, and will personally advise staff to avoid using it. Please keep logging progress here, if there is nowhere else.

Top Kudoed Authors
Labels