cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Learner II

Canvas Google Apps LTI authorization failures

Jump to solution
  • UPDATE Jan 18, 2018  —Still broken. No word on a fix....
  • UPDATE Aug 8, 2017  —Canvas recognizes this is a bug and is working on a fix (Cases #01843701, #01865357, #02000557). Not sure how or where to get updates on their progress.
  • UPDATE Aug 4, 2017  —Still broken. Still no error message suggesting the user switch browsers or login to Chrome with another account. Still many confused users getting frustrated because Canvas doesn't work Smiley Sad.
  • UPDATE Apr 24, 2017 —Still broken. Not answered. Don't let the "Assumed Answered" label fool you.
  • UPDATE Apr 20, 2017 —Still broken. No movement to fix on Instructure's part. They say it's "working as designed." If so, their design that forces students to jump through more hoops (see comments below) to access course content is a bad one. The goal should be to minimize navigation efforts and maximize access to content. The Canvas Google Apps LTI fails in this criteria.

ORIGINAL ISSUE, AS IT STILL STANDS — The Canvas Google Apps LTI authorization is failing on me in Chrome in one course (not others), and observed with faculty. Anyone else? Workarounds?The chat with Instructure support helped determine that it worked in Firefox but not Chrome. They suspected it may have something to do with being logged into multiple accounts. His boss suggested that the Google Apps LTI might need to be re-setup (by our Admin). 

Here's a screencast of the issue: Canvas Google LTI failures - YouTube 


More troubleshooting:

  1. I cleared all Instructure and Canvas cookies,
  2. then logged out of all Google accounts in Chrome,
  3. then shut down and restarted Chrome.
  4. Then opened afflicted Canvas course (https://canvas.wisc.edu/courses/39891/pages/feb-3-rubrics-in-canvas)
  5. Still saw no Google content and was asked to Authorize. Authorization fails.

Note

  • works in Incognito mode in Chrome.
  • works in other Canvas courses in Chrome.
  • works in Firefox.

Final bit of troubleshooting:

  • it seems to definitely be the Canvas tool's issue. 
  • a manual Google Doc iFrame embed works fine in Chrome, in that course.
112 Replies
Highlighted
Surveyor

2020 my course shows this same error.

however u see student view only. My worry is my class of 500 won’t see all of the course content.

i need a fix but canvas for help I’ve been on chat waiting at #99 for 3 days! I’ve called and it said 1 hour wait!

Highlighted
Surveyor

I had the same issue: cleared cookies, signed out of accounts etc, didn't work in incognito.

I resolved it by clicking "Submitted Files: (click to load)" in the panel on the right.

Edit: this was a different submission type. I still have this issue.

Highlighted

Has literally anyone figured it out?  It's so frustrating.