cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Surveyor

Canvas not supporting jpeg or png in Safari web browser

Jump to solution

When I open Canvas with Safari, images in the jpeg and png formats doesn't show in Canvas. Is there a workaround?


The problem is indeed a little surprising - I haven't noticed this problem on any other web page. In May when I noticed the problem I thought it would be solved within days or weeks, but apparently not.

I was suggested to deactivate "Prevent cross-site tracking" in Safari but it doesn't change anything.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Community Advocate
Community Advocate

Hello @lpj  Please make sure you are using the most up-to-date version of Safari, to be honest Chrome and Firefox work much better with Canvas.  I have seen pictures not show and the "submit" button not show when students use Safari.  Here is the official supported browsers for Canvas:

https://community.canvaslms.com/t5/Canvas-Basics-Guide/What-are-the-browser-and-computer-requirement...

Thanks,

Nick

View solution in original post

2 Replies
Highlighted
Community Advocate
Community Advocate

Hello @lpj  Please make sure you are using the most up-to-date version of Safari, to be honest Chrome and Firefox work much better with Canvas.  I have seen pictures not show and the "submit" button not show when students use Safari.  Here is the official supported browsers for Canvas:

https://community.canvaslms.com/t5/Canvas-Basics-Guide/What-are-the-browser-and-computer-requirement...

Thanks,

Nick

View solution in original post

Highlighted
Surveyor

Thanks!

Yes, I am using the latest version of Safari (and MacOS). It's really not a problem for me but for the students. I can tell them to use Chrome and maybe most of them will do so but they will forget and go back to Safari. 

In my understanding, showing jpeg and png images isn't that much of "rocket science" and I'm surprised that Canvas is so slow on solving this problem. I'm thinking that: either, solve the problem, or, just don't list Safari as a supported browser? 

Again, thanks for your answer.