Showing results for 
Search instead for 
Did you mean: 

Course content copy problem

I just ran across this problem today with a course that I added content to from another course.  I am looking for some feedback/comments on this issue.  Is it a problem/bug that needs to be fixed?  Is there something that I need to do differently when importing that type of page? I performed the import by selecting content to import(it was not the complete class).

In my old course, I created a page that had a link to an assignment in the course.  When I copy that page to the new course, the link stays active and points to the old course assignment.   Links to files are okay and transfer to the files in the new course.  I can see the course ID number in the URL on the old course page and on the transferred page to the new course.  In the case of the file links, the course id changed and in the case of the link to the assignment the course id number did not change.

I forgot to mention.  I played around some with one of my dummy students and copied a page link directly from a course the dummy student had been enrolled in, copied that to a link on a page in my playground.  The dummy student was able to access all the content on that page - assignment and pdf files.

14 Replies

 @Renee_Carney ​

Nice graphic. Smiley Happy.  Any idea about the letter j in the help ticket description window?

I have no idea why you would not be able to type the letter j in the ticket?  I'm sure you tested your keyboard and letter j in other windows (clearly you could type it here!).

Will you see if clearing your cache and history in your browser along with closing out your browser and starting fresh might help?

 @Renee_Carney ​

I reset my browser and I can now type the j.  No idea what happened with that one.

Community Member

I would have to play around more with this

Community Member

Hi  @bowmanr ​ - we have the same problem all the time, typically with Discussions and follow-up Reply assignments. My understanding was that it depends on the way the link is created. An absolute link (copied directly from the URL) would cause this, but a link created from within the Canvas course (from the resources listed on the right sidebar) will be OK when copied forward.

However when I tried to confirm this today before replying, I found this was NOT the case - links created through either method worked just fine when copied forward. Maybe this is something that was corrected at some point...??