cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Member

Embedded Google Doc, links do not work

I have embedded a google doc to a page, there are hyperlinks on the google doc.  They don't work on the embedded google doc but they do work when I click on them with the google doc open.  What do I need to do to fix this?

8 Replies
Highlighted
Community Advocate
Community Advocate

Hi hsargent@wolves.k12.mo.us‌ - Yep; I see what you're talking about.  Students get a Canvas redirect page, and then it still does not open.  The main issue is that Google does not seem to allow you to embed a hyperlink so that it loads in a new tab by adjusting the underlying code.  I had a feeling that this issue has been brought up before, and indeed our awesome Community has spoken about it here:  Embedding Google Doc with Links .  I personally have not tried some of the other suggestions mentioned, but unfortunately I believe the best suggestion without getting too deep in the weeds of programming solutions is to either:

  • Instruct students to right-click over the hyperlink within the embedded document, and then left-click the link, which is mentioned in the link above OR
  • Copy/paste the contents of your Google Doc page into a regular, newly-created Canvas page.  I tried this with a rather simple Google Doc with a few hyperlinks, and the hyperlinks DID continue to work just fine in Canvas. 

I assume that you may have your reasons for embedded the Google Doc, to begin with, rather than creating a page, so the first one may have to be the one to use in your case.

Hope this helps a bit, Heather.  Perhaps some more brilliant minds than me in the Canvas Community have found a solution themselves.

Highlighted
Community Coach
Community Coach

Hello there, hsargent@wolves.k12.mo.us...

I have been reviewing older questions here in the Canvas Community, and I stumbled upon your question.  I wanted to check in with you because I noticed that we have not heard back from you since you first posted your question on October 17, 2018.  It looks like kblack@dom.edu‌ replied to you a day later.  Have you had an opportunity to review Ken's feedback?  Has is response helped to answer your question?  Or, are you still looking for some help with your original question?  If you feel that Ken's feedback has helped to answer your question, please feel free to mark his answer as "Correct".  However, if you are still looking for some assistance from Community members, please let us know by posting a message below.  For the time being, I am going to mark your question as "Assumed Answered", but that won't prevent you or others from posting additional questions an/or comments below that are related to this topic.  I hope that's alright with you, Heather.  Looking forward to hearing back from you soon.

Highlighted

I am currently having this issue. I have made a Google Slide and attached links to certain parts of the slide. It works fine in Google. I upload it to Canvas, and the links no longer work. Any suggestions would be greatly appreciated right now! We start school in 4 days and nothing is working. Please reply as soon as you can. Thank you!

Highlighted

I'm having the same issue. My links in another course open, but not the other two. I even tried copying the code for the course that works and...nothing. Please help!

Highlighted
Highlighted

Thank you! Thank you! Thank you!

0 Kudos
Highlighted

Melanie1913_0-1597341279646.png

Step 5 - says Click the Files tab on the right...I don't see files on the right...Are you speaking of the Files on the left side of my screenshot??? I am sssoooo close! Thanks for your help thus far. I did click the Files tab on the left hand side and clicked upload...then the other directions didn't match and I stopped. Lol!

0 Kudos
Highlighted

OH BOY! OH BOY! I GOT IT! I GOT IT! THANK YOU.

0 Kudos
Labels