cancel
Showing results for 
Search instead for 
Did you mean: 
jane_downing
Community Member

Embedding a .swf

Jump to solution

Embedding a .swf.

I am trying to embed a .swf in a course and cannot get it to display. I have tried the instructions but have had no luck.

Thanks.

Tags (4)
1 Solution

Accepted Solutions

Hi  @jane_downing ​...

Give this a try...it seemed to work for me:

<p><iframe src="https://media.ccconline.org/ccco/FacWiki/TeachingResources/Blooms_Taxonomy_Tutorials/BloomsTaxonomy_... " width="###" height="###"></iframe></p>

NOTE: You'll need to paste in the entire URL that is pointing to the SWF.  It's not displaying entirely here.  Also, adjust the green "#" signs with the width and height of your flash file.  Finally, I added "s" to "http" = "https".

Hope this helps!

View solution in original post

6 Replies
chofer
Community Coach
Community Coach

Hello  @jane_downing ​...

I'm not sure if you are referring to this blog that I wrote a while back, but are these the instructions you are referring to?  Embedding Flash (SWF) Animations in Canvas (this is in the Instructional Designers group here in the Canvas Community...so if you have not yet joined that group, you can do so by clicking on the "Follow" button at the top right corner of the page).  You can post questions below my blog if you want, and I'll try to help answer there, too.

Chris,

You seem to understand this very well.  We are having an issue of the .swf files playing but missing images (like math equations).  Do you think you could help me/ our division with this?  Thanks in advance!  @chofer ​

Hi  @david_dick ​...

Unfortunately, I don't think I'll be much help diagnosing the issue you're having.  My experience with Flash isn't stellar, and I only know basic ActionScript coding.  You'd have to have the original source file for your Flash file rather than just the *.swf file.  Missing images in the Flash file doesn't sound normal.  If the images were showing up when designing the animation, I would think they would show up when compiling the *.swf file.

I'm sorry I don't have better news for you.  Smiley Sad

Hi  @jane_downing ​...

Give this a try...it seemed to work for me:

<p><iframe src="https://media.ccconline.org/ccco/FacWiki/TeachingResources/Blooms_Taxonomy_Tutorials/BloomsTaxonomy_... " width="###" height="###"></iframe></p>

NOTE: You'll need to paste in the entire URL that is pointing to the SWF.  It's not displaying entirely here.  Also, adjust the green "#" signs with the width and height of your flash file.  Finally, I added "s" to "http" = "https".

Hope this helps!

View solution in original post

 @jane_downing ​

Did this solution work for you?