cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Surveyor

Google Assignments (LTI 1.3) Not Submitting

I attempted to use the Google Assignments integration this week with my classes. It seemed everything was working right on my end (I was able to attach the document using external tool and was able to preview the assignment). I had multiple students e-mail me today that they are having trouble getting the assignment to submit. When I open up the assignment to view the submissions, there are none. I added a fellow teacher to my class and had them submit the assignment. Their submission did not show up (I literally watched them hit the submit button and saw that it said submitted).

I can login to my Google Drive and see the student work in the folder that was created for the assignment but cannot see it in Canvas.

Is there a glitch in the integration that is causing it not to show student submissions? Is there something additional I need to do to see their submissions?

26 Replies
Highlighted
Surveyor

Following! I am having the same issue. 

I had a Google Cloud assignment on Canvas today. The only thing I did different was making it launch in a new tab. Students were able to access it fine and work on it no problem. I allowed two students to share their screen and watched them submit the assignment. I had several other students say they submitted it as well. However, when I go to SpeedGrader, it shows that none of my students have turned it in and says "This student does not have a submission for this assignment." I know for a fact these students submitted the assignment. I really need to start grading assignments. My district doesn't have it set up to create a Google Folder for me to find their work in either, so I am completely at a loss.

Highlighted

@jlondon90 You have to grade the submissions in Google. When teachers click on the assignment, they will see see submissions. They grade in Google and the score updates in Speedgrader. 

See screencast here.

Good luck!

Highlighted

The problem is that the Submissions are not showing up in the Canvas assignment.  It still says "no submissions yet" even when all my students submitted and I can see their assignments in my Google Drive.

Highlighted

Ah! That is a very different issue. We have not encountered that one yet. Thank you for clarifying! I'd put in a ticket for sure. 

Highlighted

Does it say no submissions in the Speed Grader or in the Google Assignments part of the assignment. If it is the former then it is acting as it should, now, but if it is not showing up inside the Google Assignment then you need to confirm that students exist their doc, sheet, or slide and submit inside the Google Assignment part of the assignment.

0 Kudos
Highlighted
Surveyor

I am having the same problem

Highlighted
Surveyor

One of the teachers at my school figured out the following:

  • Google Docs Cloud Assignments make a copy and can be submitted in Canvas.
  • Google Assignments (LTI 1.3) is used to integrate a Google Classroom into Canvas. 

SO the short of it is,

  • if you are using Google Classroom, use Google Assignments (LTI 1.3).
  • if you are just using a Google Doc, use Google Doc Cloud Assignment.

At least, this is what we were able to figure out.

0 Kudos
Highlighted

Next summer I have been told the old Google cloud assignment will go away. Make sure your students exit their doc before submission. The speedgrader is supposed to be blank until you grade it in the Google assignment submission section. THEN your speedgrader will show the score. Rumor has it eventually you'll be able to grade in either place, but not yet.

0 Kudos
Highlighted
Surveyor

Multiple teachers here are having the same problem.  In SpeedGrader, the submission is a blank page even though the assignment was a Google Doc loaded through the Google Docs Cloud Assignment LTI.  This error just started this morning.  Before then, everything loaded through Google Docs Cloud Assignments was working. 

 

 

Top Kudoed Authors
Labels