cancel
Showing results for 
Search instead for 
Did you mean: 
Surveyor

Help - Copying a new quiz that draws on a question bank produces an empty copy that can't be edited!

Looking for some help making a copy of a "New Quiz"

I made a "New Quiz" that draws questions from a set of question banks. 

Now I'd like to make a copy of this "New Quiz" into the exact same course.  I can use the "Copy To" function that is now available with a New Quiz, but when I do--the copy shows the quiz sections but is no longer linked to the question banks (even though they still exist and are in the same course).  Even worse, it is no longer possible to edit the quiz sections to relink them to the question banks.

Has anyone else run into this?  I'm struggling to try to figure out a solution.  I've tried the old way of copying quizzes by using a course import but get the same result. 

 

Any help or pointers much appreciated.

Bob

 

Here's the copy of the quiz--you can see each section is no longer linked to a question bank. 

2020-10-03 19_55_33-Exam 1.png

2020-10-03 19_55_50-Exam 1.png

And here's the original--it has sections that draw from question banks and all is working just fine!

0 Kudos
2 Replies
Surveyor II

I am having the exact same problem!  So the copy function is not really a copy in this case. I thought it was strange that you cannot even edit the group to re-link it to the bank. You have to completely re-write your group question to get to the bank. I submitted a ticket to Canvas. If you have a response from Canvas I would love to know.

Surveyor II

I received an email back from Canvas (see below). I hate using the QTI zip file method to copy quizzes---so cumbersome compared to "copy to". 

Minimally, a popup warning would be nice when instructors are about to copy a quiz, warning them about this specific question bank issue.

 

 

Hi Carrie!

Thank you for contacting Canvas Support! 

I am sorry to see that you are having issues with the copying quiz function, I am more than happy to assist you with this. 

I have taken a look into this for you and I have been able to see that " If you set a question group to randomly select questions from the question bank, the question bank and questions will not be included in quiz exports. A QTI zip file will download the quiz details, but no questions will be included." (https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-create-a-quiz-with-a-question-group-to-...) so this is why the questions in the question group are not getting imported across. 

If you have quizzes with question banks linked I would recommend that you also import across the questions to the other course and then you can just re-create the question group linked to the question bank. 

Let me know if you have any questions!

Have a great day!

Oliver
L1 Canvas Support
support@instructure.com