cancel
Showing results for 
Search instead for 
Did you mean: 
sdavick
Community Member

IOS App not showing Google Form

Jump to solution

Has anyone had trouble with an embedded google form not showing up in the ios app?

It is visible on the website, but not in the app.

2 Solutions

Accepted Solutions
chofer
Community Coach
Community Coach

Hi  @sdavick ‌...

I just navigated to a Google Form I've had set up in a course for more than a year using my iPhone and the official Canavs mobile app.  I didn't have any problems viewing the form.  I could even tap on the fields to enter in text to submit on the form.  Are your sharing rights enabled so that you and others can see the form without having to sign in to see it?

View solution in original post

0 Kudos
rseilham
Community Coach
Community Coach

 @bbritche ‌ and  @sdavick ‌

Okay, so I think I figured it out. If you have "Sign in" required on your form, it won't work in the app. It should, but doesn't. In your form, try turning off "Require Sign In" (It's in the settings, gear icon, next to send). Then exit out of the app and try again. It worked for me. 

247277_Screen_Shot_2017-08-21_at_1_10_42_PM.png

View solution in original post

13 Replies
chofer
Community Coach
Community Coach

Hi  @sdavick ‌...

I just navigated to a Google Form I've had set up in a course for more than a year using my iPhone and the official Canavs mobile app.  I didn't have any problems viewing the form.  I could even tap on the fields to enter in text to submit on the form.  Are your sharing rights enabled so that you and others can see the form without having to sign in to see it?

View solution in original post

0 Kudos
sdavick
Community Member

We have embedded the form on a Canvas page and have a link to that page at the bottom of each assignment.It is a Google form our students fill out at the end of class every day. No one has trouble accessing it from our Chromebooks when they are on the Canvas website or even from on the website when on their iPads. If they are in the app the form never shows up. The page is blank.

It is a mystery I'd like to solve Smiley Happy

rseilham
Community Coach
Community Coach

I just tried embedding a Google Form, which I have in the past and it worked just fine. I could see and submit the form using Google Forms. If possible, could you share your embed code? I'd like to test it on our end. Even if it's just a dummy form with a few questions. Thanks! 

sdavick
Community Member

Thanks for taking a look at this!

Here is the embed code we are using on that page: 

<p><iframe style="display: block; margin-left: auto; margin-right: auto;" src="https://docs.google.com/forms/d/e/1FAIpQLSeYA7U4yVuMLivC99gS7-iKVIFPN2m7ECmGwVNbcfLfbxZH_Q/viewform?..." width="760" height="2400">Loading...</iframe></p>

This was the original code copied from the form. I believe the only change I made was to the height of the iframe and then I centered it using the rich content menu.

<iframe src="https://docs.google.com/a/ccsk12.com/forms/d/e/1FAIpQLSeYA7U4yVuMLivC99gS7-iKVIFPN2m7ECmGwVNbcfLfbxZ..." width="760" height="500" frameborder="0" marginheight="0" marginwidth="0">Loading...</iframe>

Here is what I see in  my Firefox browser on my pc:

218533_GoogleFormFirefox.jpg

This is what I see in safari on my iPad:

218534_image2.PNG

This is what I see in the Canvas App on my iPad:

218535_image1.PNG

sdavick
Community Member

I see now that one of your questions was about the sharing rights. Even though in the screenshots I shared it says I don't have permission to view the form, our students have been filling out these forms every day for the entire year. The permissions are set for anyone within our organization to have access. I don't think this would be the issue (although I could be wrong).

We were using another LMS until about a month ago. We have only just now switched to Canvas. It took me a couple of weeks to realize that our students couldn't access the form in the app. Often they are on the Chromebook because our previous LMS didn't have an app. More of our students prefer to use the Canvas app than I originally expected. Those who do have been frustrated by this because they are required to complete this form at the end of class and that means they have to log in another place in order to do that.

chofer
Community Coach
Community Coach

Hi  @sdavick ‌...

I thought I would check in with you because it's been since the end of February without any new activity in this particular discussion thread.  Are you still having issues with viewing embedded Google forms inside of the Canvas app?  Or, have you found a solution?  If you did find a solution, would you mind sharing that here in the Canvas Community?  If you're still looking for some help, however, please let us know that as well.  For now, I am going to mark your question as "Assumed Answered" because there hasn't been much activity in this thread for quite some time.  Other people will still be able to post message below, however.  I hope this is okay with you.  Looking forward to hearing from you, Sara.

bbritche
Surveyor

I know this has been coded as "assumed answered," but I'm having the same issue I can see the form just fine when using a desktop, but on iOS, there's nothing there. 

rseilham
Community Coach
Community Coach

 @bbritche ‌, 

I'm sorry this is still causing you issues. I tested out your code and could not get it to load in the mobile app. So I went and created my own form and used the embed code from that form and....it worked?  Here's the proof. 

247189_IMG_3502.PNG

Can you try this code in a course and let me know if it works in the app? 

<p><iframe src="https://docs.google.com/forms/d/e/1FAIpQLSfz3jg4x2AtgPciX0nOdoKKptpl65Q9DGGcxbeMzk7L5dBRMA/viewform?embedded=true" width="95%" height="500">Loading...</iframe></p>‍

Yes! That worked. I compared the lines of code you have there against my own, and it seems they're basically the same. Any ideas what the difference might be?