Showing results for 
Search instead for 
Did you mean: 
Surveyor II

Indentation of bullet items longer than one line

When composing a page of text, bullet lists look neater when all the text, including items longer than one line, exhibit the same indentation.

For example:

  • short item
  • a really really really long item that wraps around to form an additional line of text within the same bullet item that should indent the second line the same as the first
  • an item with soft returns
    the second line
    the third line

This is how bullet lists behave in Edit mode.



However, in Read mode, the additional lines in a bullet item don't indent.



How can I fix, or work around, that?

0 Kudos
8 Replies
Community Coach
Community Coach

Hi @grassedd 


When I first read your question, I went, "What?", because I have only seen this behavior when copying/pasting from an MS Word or PDF document where the Canvas editor sometimes struggles with formatting.

So I tested this in my sandbox, using some text from your post. This is what I got after saving.......


Note, the indenting for the second item is consistent.

So, now I am really confused. Perhaps someone else will be able to explain this behavior, because I cannot reporduce it.


Tags (1)
Surveyor II

Thanks so much, kmeeusen, for looking at this.

Your reply made me think my issue was an isolated glitch.  (Yes, some embarrassment for posting it, but more than some relief that things would work.)

Unfortunately, I cannot not reproduce it, even in different courses.  I'll spend some time testing it out in different circumstances.

(Newly tested screenshots attached)

Community Coach
Community Coach

Hi! Within the course with the uncommon indentation, could you highlight the text, and then clear the formatting? (That's the T with the slash through it.) Sometimes, resetting the formatting and then re-establishing your preferences can help.

Thanks, klundstrum, for responding.

I started a fresh page, manually keyed in the text, cleared the formatting, applied bullets, and saved with the same result.  With the same page, I entered Edit mode, selected all the text and cleared formatting again, then saved.  Still no change.

Edit mode:


Read mode:


While I appreciate the comments so far, I'm puzzled that no one has come forward with the same issue.  Clearly, some setting or environment on my end causes it.

(In case you want to watch it happen, here's a screencast of me making a page with a bullet list, similar to the one above.  It's 1:40 in length, but if you don't care to watch all the typing, just go the last ten seconds.)

Good evening, @grassedd ...

What does the HTML code look like for the example you've been sharing with us?  Maybe it would help for us to see if there is some rogue code on your page that is causing the text to not align correctly?  I watched your video that you posted, and it looks like you were using the New RCE (Rich Content Editor).  I also tried a similar bulleted list, but I was not able to replicate what you are experiencing.

Looking forward to hearing back from you soon.  Take care, stay safe, and be well.

Surveyor II

Thanks, chofer, for the reply and for the suggestion.

Edit mode (RCE):



Edit mode (HTML):



Read mode:



Hi @grassedd ...

There must be something within your browser that is causing this to be different than what I'm able to see within my own sandbox course.  I am still unable to replicate this on my end.  Here are some screen shots:

Editing text in the New RCE


HTML View (not sure why it's putting the <span> tags in there...or why they are really necessary for an unordered list.  The classic RCE doesn't usually put <span> tags in.)


View of the saved page


Have you considered reaching out to Canvas Support to see if they can help troubleshoot?  How do I get help with Canvas as an instructor?  Your HTML code that you shared looks sound, so I'm not sure why it would be displaying differently for you than what I am showing in my own screen shots.

Please keep us posted here in the Community...thanks!


Yes, I am satisfied that this has moved from a "how to" to troubleshooting.