cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Surveyor

Multi-level numbered lists

Jump to solution

Hello!

I've been fighting with this for about an hour using the RCE and realized I could ask the question here!! I need to create a multi-level list. When I paste my content into the editor, it only lists numbers in each of the levels. There is a screenshot below. Thanks in advance for any assistance!

I would like to achieve this:

  1. level 1
    1. level 2
    2. level 2
      1. level 3
      2. level 3

This is what I see...

Screenshot of my list

1 Solution

Accepted Solutions
Highlighted
Navigator

cchapman@coastline.edu​,

There are possibly two issues going on here, including one that you are probably not aware of.

The Rich Content Editor (RCE) improperly nests lists. The specification states that the sub-list belongs to the item above it. That is the second <ol> ... </ol> is within a <li> ... </li> on the parent list. Most people don't notice this unless you mix <ol> and <ul>.

The second is the one that you asked about. To get those, you need to specify the list-style-type. The list of allowed tags in Canvas' RCE says that the type is allowed for the <ol> tag, but it was deprecated in HTML 4 and reintroduced in HTML 5. However, there is a note that unless the value matters like legal or technical documents where you refer to items by their number, you should use the list-style-type instead.

Here's what it would look like (the style type is optional on the first one since it defaults to decimal).

<ol style="list-style-type: decimal;">

  <li>level 1

    <ol style="list-style-type: lower-alpha;">

      <li>level 2</li>

      <li>level 2

        <ol style="list-style-type: lower-roman;">

          <li>level 3</li>

          <li>level 3</li>

        </ol>

      </li>

    </ol>

  </li>

</ol>

Here's a nifty trick. I just copy/pasted what you were looking for from your message into the Rich Content Editor and it came out correctly. I didn't even have to retype it. I did pull it into Dreamweaver to apply some indentation for clarity of my first point, but this was a lot easier than I thought it was going to be. I couldn't do that with what you are seeing since that's an image, but you should be able to go through and 1) fix the nesting and 2) add the list-style-type into the style attribute.

View solution in original post

3 Replies
Highlighted
Navigator

cchapman@coastline.edu​,

There are possibly two issues going on here, including one that you are probably not aware of.

The Rich Content Editor (RCE) improperly nests lists. The specification states that the sub-list belongs to the item above it. That is the second <ol> ... </ol> is within a <li> ... </li> on the parent list. Most people don't notice this unless you mix <ol> and <ul>.

The second is the one that you asked about. To get those, you need to specify the list-style-type. The list of allowed tags in Canvas' RCE says that the type is allowed for the <ol> tag, but it was deprecated in HTML 4 and reintroduced in HTML 5. However, there is a note that unless the value matters like legal or technical documents where you refer to items by their number, you should use the list-style-type instead.

Here's what it would look like (the style type is optional on the first one since it defaults to decimal).

<ol style="list-style-type: decimal;">

  <li>level 1

    <ol style="list-style-type: lower-alpha;">

      <li>level 2</li>

      <li>level 2

        <ol style="list-style-type: lower-roman;">

          <li>level 3</li>

          <li>level 3</li>

        </ol>

      </li>

    </ol>

  </li>

</ol>

Here's a nifty trick. I just copy/pasted what you were looking for from your message into the Rich Content Editor and it came out correctly. I didn't even have to retype it. I did pull it into Dreamweaver to apply some indentation for clarity of my first point, but this was a lot easier than I thought it was going to be. I couldn't do that with what you are seeing since that's an image, but you should be able to go through and 1) fix the nesting and 2) add the list-style-type into the style attribute.

View solution in original post

Highlighted

It would be real nice if Canvas could fix this issue.

Highlighted

This does not work in quiz creation.  I tried it and it comes out with the tags showing and no enumerated list (outline) at all.

Also, your "solutiion" does not produce letter labeled enumerations downlevel, and the OP asked for that.  Your approach uses numerals for all levels.  I want to change the enumeration labels from numbers to letters like so:

(a)   This is an item in my enumerated list.

(b)  This is the next item in my enumerated list.

(c)  This is the third item in my enumerated list.

I find that in the question editing tool, there is no option for changing the enumeration tags at all.  In fact, this editor for this forum is better in this regard than in the quiz editing tool, because it at least provides a way to create lists enumerated by systems other than numerals.  For example:  

  1. This is an item in my enumerated list.

  2.   This is the next item in my enumerated list.

  3.   This is the third item in my enumerated list.

or 

  1. This is an item in my enumerated list.
  2. This is the next item in my enumerated list.
  3. This is the third item in my enumerated list.

Neither of these options is available for quizzes, and I don't have time to rebuild the quiz editor from scratch to make up for instructure notbuilding it right in the first place.  

One way this could have been done better would be to allow enumeration in the LaTeX advanced view in the equation editor, but for some reason, the quiz editing tool. disables most LaTeX commands, even in the advanced view.  

Top Kudoed Authors
Labels