cancel
Showing results for 
Search instead for 
Did you mean: 
lori_campbell
Surveyor II

My gif isn't giffing.

Jump to solution

I normally use gifs for my course view cards. However, 2 out of 6 of mine are moving on the course settings page but not in the actual card view. This is only annoying me. I am sure it's not a big deal to the students, but I like the animation on the dashboard because I am "that kind of teacher." Does anyone else have this issue? I haven't checked yet with a student to see if the gif moves for them.

Tags (2)
27 Replies
bbennett2
Navigator II

I did some digging because we had some GIFs as card headers too and I noticed that ours aren't giffing either.

I opened the dev tools in Chrome and took a look at how the image is loaded. This is the URL on the page:

https://inst-fs-iad-prod.inscloudgate.net/files/1233asdfLongStringHere/engage.gif?download=1&token=AnotherLong12345JumblyString&geometry=262x146&format=webp

Two things to notice:

  • The gif is actually loaded
  • The format is converted to webp

WebP is a new web image framework from Google that keeps high quality images without having a huge file. They allow for animation, so I'm assuming when you upload, there's some kind of conversion process that turns the GIF into a WebP file to make storage more manageable.

I tried converting a GIF to WebP, which gave me an animated image, but the Canvas Settings don't allow for WebP uploads as images, so that's not a solution. Not sure why it's happening, but it definitely isn't uer error.

diana_benavides
Community Member

Same here. It is now December 2019 and the gifs on the course cards are not giffing. I just tried on different course cards and tried from different sources (websites)

Any luck anyone?

tbrecheisen
Surveyor

Not sure if this the answer, but I noticed when I'm in the Instructor view, the gifs don't gif.  If I try to view the Dashboard with the Student View, I can't.  However, if I go to the Android App, my gifs are giffing nicely.  So, I asked a student what they experience, and they said they see them gif correctly.  Just reporting.

jalexander
Community Member

I am having the same problem.  Interestingly, some gifs ARE still working.  These are files I uploaded about two years ago.  Ones I have added to more recent courses do not animate, even when they worked just fine before.  Here's a link to my dashboard--you can see some gifs giffing, some not : Canvas Gifs 

tyler_witman
Learner II

As others have mentioned in previous replies, I've seen instances where some gifs will play and others won't with no rhyme or reason. After submitting a support ticket, I also got a response that it is a known issue that is being worked on. 

bbennett2
Navigator II

Just to have everyone check, I logged into our beta instance today and all GIFs are working again. Looks like it'll be in the Jan 20th update.

We are seeing them work just fine in test, but no motion in the production instance.

I too have an un-giffed .gif file on production that is running fine on Beta.  

Doctor Horrible crossing fingers, captioned with "Fingers crossed"

Hope the next update fixes the issue!

jackiejohansen
Surveyor

Hi everyone- I am about to start my new semester and I am also not giffing. Thank you all for posting; I do hope this gets fixed soon. I kinda feel like I did when I was at zoo and I dropped my ice cream cone. Such a letdown.

bea9
Community Member

My course images are also not animating at this point. Smiley Sad