cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Recording Video File from Chrome / Google Blocking Java or Flash

Jump to solution

Hi all I am trying to record a video file from my chrome browser to canvas to upload. It asks me for a flash player which I intalled . I am running 8.1 on my laptop and have java and flash l64 bit loaded but Google seems to have some sort of a block on the Java and or Flash player?? Helpp

1 Solution

Accepted Solutions
Navigator

I'm running the 64 bit version of Chrome on Windows 8.1 and had heard about Chrome dropping support for NPAPI stuff,which includes Java (Oracle has their own page about this issue), Facebook Video, Google Talk, and some other plugins. Supposedly that finally happened with version 42 of Chrome. There is a question in the Community about videos not working correctly that might be related.

Since I'm teaching an online class for the first time this summer and suggesting students use Chrome and possibly their webcams for some conferencing, I decided I better double check things. I took this opportunity to unbox a new webcam I had bought around Valentine's Day and was ready to try John's suggestion about enabling Flash through the chrome:plugins page.

It turns out that I didn't have to because mine was already enabled.

So, if you're in the same boat and have Flash enabled and are still looking for answers, here's what I had to do ... no guarantees it will work for you.

I had to make sure the Webcam was working properly first. To do this, I had to download software from the Logitech site. You've probably already done that, but make sure the problem is specific to Chrome and not in general. You could test it in FireFox, which still supports the NPAPI.

Then, in Canvas, when I clicked on the record media button, I did the following.

I waited. And waited. And waited.

Then I waited some more. Eventually it came up with Please Select Your Camera -- I chose the Logitech Webcam instead of the other drivers it found

When it came up with Adobe Flash Player Settings, I did the following. (If it doesn't come up, you can right click on the video window and choose Settings):

  • Under Adobe Flash Player Settings, I told it to allow Canvas to access your camera and microphone and to remember it.
  • Under the Microphone, I increased the volume and told it to reduce echo. I also told it to use the microphone on the webcam, although this was working properly with the Default microphone since I didn't have another one plugged in at the time.
  • Under the Camera, I chose the Logitech camera instead of the other drivers it had

When I first got this working, I was using version 42 of Google Chrome. I went to get the version number to put in here and it decided to update to version 43. I can say that it still works with version 43 of Chrome.

Here are the versions of things so you can compare.

Chrome:Version 43.0.2357.65 m (64-bit)

Adobe Flash: Version: 17.0.0.188 (This is using PPAPI Pepper Plugin API instead of NPAPI).

Logitech HD Pro Webcam C920

I don't have a machine with a 32 bit version of Chrome, but I thought you might be using 64 bit since you mentioned the 64 bit version of Flash.

I did notice that my Adobe Flash was using PPAPI (Pepper Plugin API), You can tell this from the chrome://plugins screen if you click on the Details expansion button. If you're still running NPAPI that might be the issue there and upgrading to the correct type of Flash might help. When you go to download Flash, it will ask you to select PPAPI or NPAPI. I didn't do that, so somewhere my system figured out that I needed it.

Anyway, I hope it's as simple as John's suggestion and just enabling Flash.

View solution in original post

4 Replies
Learner II

If you are using Windows 8.1, are you launching your browser from the new Metro-style interface or the traditional desktop environment?​

Also, for chrome, you may need to be sure that the Flash plugin is actually enabled.

Type chrome:plugins in the address bar to open the Plug-ins page.

On the Plug-ins page that appears, find the "Flash" listing.

To enable Adobe Flash Player, click the Enable link under its name.

Community Coach
Community Coach

Deactivated user​, I wanted to let you know that I shortened the title of your post since you it appears you had the same text in the body of your message.  I also tagged your post with keywords so that it would be easier for people who are searching.

Navigator

I'm running the 64 bit version of Chrome on Windows 8.1 and had heard about Chrome dropping support for NPAPI stuff,which includes Java (Oracle has their own page about this issue), Facebook Video, Google Talk, and some other plugins. Supposedly that finally happened with version 42 of Chrome. There is a question in the Community about videos not working correctly that might be related.

Since I'm teaching an online class for the first time this summer and suggesting students use Chrome and possibly their webcams for some conferencing, I decided I better double check things. I took this opportunity to unbox a new webcam I had bought around Valentine's Day and was ready to try John's suggestion about enabling Flash through the chrome:plugins page.

It turns out that I didn't have to because mine was already enabled.

So, if you're in the same boat and have Flash enabled and are still looking for answers, here's what I had to do ... no guarantees it will work for you.

I had to make sure the Webcam was working properly first. To do this, I had to download software from the Logitech site. You've probably already done that, but make sure the problem is specific to Chrome and not in general. You could test it in FireFox, which still supports the NPAPI.

Then, in Canvas, when I clicked on the record media button, I did the following.

I waited. And waited. And waited.

Then I waited some more. Eventually it came up with Please Select Your Camera -- I chose the Logitech Webcam instead of the other drivers it found

When it came up with Adobe Flash Player Settings, I did the following. (If it doesn't come up, you can right click on the video window and choose Settings):

  • Under Adobe Flash Player Settings, I told it to allow Canvas to access your camera and microphone and to remember it.
  • Under the Microphone, I increased the volume and told it to reduce echo. I also told it to use the microphone on the webcam, although this was working properly with the Default microphone since I didn't have another one plugged in at the time.
  • Under the Camera, I chose the Logitech camera instead of the other drivers it had

When I first got this working, I was using version 42 of Google Chrome. I went to get the version number to put in here and it decided to update to version 43. I can say that it still works with version 43 of Chrome.

Here are the versions of things so you can compare.

Chrome:Version 43.0.2357.65 m (64-bit)

Adobe Flash: Version: 17.0.0.188 (This is using PPAPI Pepper Plugin API instead of NPAPI).

Logitech HD Pro Webcam C920

I don't have a machine with a 32 bit version of Chrome, but I thought you might be using 64 bit since you mentioned the 64 bit version of Flash.

I did notice that my Adobe Flash was using PPAPI (Pepper Plugin API), You can tell this from the chrome://plugins screen if you click on the Details expansion button. If you're still running NPAPI that might be the issue there and upgrading to the correct type of Flash might help. When you go to download Flash, it will ask you to select PPAPI or NPAPI. I didn't do that, so somewhere my system figured out that I needed it.

Anyway, I hope it's as simple as John's suggestion and just enabling Flash.

View solution in original post

Community Coach
Community Coach

Deactivated user​, did any of these suggestions work for you?