Showing results for 
Search instead for 
Did you mean: 

Space bar issue

Jump to solution

Quite recently I have been having an issue of using the space bar.  Sometimes it simply does not work in Canvas.

Then, I will backspace and delete what I wrote and it starts working again...but could just as easily stop.

This is not a problem with my keyboard (as you can see) and rebooting did not solve the problem.  

It is a frustrating bug because the issue is intermittent.  

I am using Chrome, so the issue may deal with the interaction between the browser and Canvas. 



73 Replies

I have this problem, also.  The space bar works in all other apps, even on my browser, just not in the rich content editor in Canvas.  I CAN use the space in the middle of text, just not at the end of a line.  If I put a period, I can type normally in front of the period.


This is NOT solved. It just happened to me, over a year and a half later. 

Yes, I'm using Chrome. But no, I was just typing - I had not pasted or made a bulleted list or anything fancy. I had just hit the [Enter] key for a new paragraph -- and my first space was impossible to make. It's a fairly new machine for me, so I thought it was at fault, and went to try in another tab, just randomly searching for it -- and the [Spacebar] worked, and brought me here. 

At least I have the type-a-period-and-then-go-back-before-it "solution." 

Please, don't we deserve a real fix? And PLEASE don't close questions that are still an acknowledged big problem -- UNLESS IT IS ACTUALLY FIXED! 

Thanks for listening! 

We are seeing this issue too. The problem has been known for more than a year, why isn't there a fix yet Canvas folks? 



update as of 27 Feb 2021

the issue persists. the hack on putting a period and going back to type inside it WORKS. So far it's a minor inconvenience, but is annoying