cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Member

Why am I always getting a message that says my Browser does not meet requirements/needs updating?

Every time I connect to Canvas or try to do anything with Canvas a message always comes down and says

that my browser has not been updated.

Please help me.

0 Kudos
2 Replies
Highlighted
Community Advocate
Community Advocate

Howdy! Hope all is well. Thank you for sharing your question with us.

You might not be using a supported browser or supported browser version. This link provides the supported browsers/versions for Canvas.

Hope that helps,

Sky V. King, FIU Online

Tags (1)
0 Kudos
Highlighted
Community Coach
Community Coach

Hi @nwaters1 ...

Generally speaking, having an up-to-date web browser is a good idea.  It's common knowledge with people here in the Community that using either Google Chrome or Mozilla Firefox will be your best choices when navigating around the Canvas environment.  Are you using either of these browser?  Have you tried using either or both of those browsers to see if your experience is any better in Canvas?  Check out this Guide: What are the browser and computer requirements for Canvas?.  You might also consider clearing your browser cache to see if that helps, too.

I hope this information will be of help to you.  Sing out if you have any other questions about this...thanks!  Take care, stay safe, be well.

0 Kudos
Labels