cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Surveyor

Why are my submit assignment buttons missing?

Jump to solution

I transferred my class from last year and am setting up my next years summer assignment.  Everything appears to be working smoothly on the transfer except that the students don't have a submit assignment button on the assignments.  When I go look at the assignments in student view, the button is there.  The assignment is due on August 20th of 2018 (in the future) and the start date is in March of 2018 (the past).  The course is published and all the assignments show a green check mark as though everything is good.  Any ideas?

1 Solution

Accepted Solutions
Highlighted

jmaclean@tvusd.k12.ca.us, you might want to check the section dates. You should be able to see this by going to your course settings and clicking on "Sections." Click on the name of a section and then click "Edit Section." Check these dates to make sure there isn't a conflict with your regular course setting dates.  

View solution in original post

10 Replies
Highlighted
Community Coach
Community Coach

Hi jmaclean@tvusd.k12.ca.us

I know this may sound like a silly questions, but...........

Did you set a Submission Type for the assignment?

Kelley278542_pastedImage_2.png

Highlighted
Surveyor

I have it set-up as a online submission, file uploads restricted to pdf,jpg,png,bmp types of files.  It works for me a student view, but doesn't show up for the kids when they login.

Highlighted

Silly question, but when is the "Until" date set for? Also, is this a regular assignment or does it involve some type of LTI or other third-party application?

Highlighted
Surveyor

One of my students said that a hovering green "announcement" said that "This course hasn't started yet......"   The course is set to begin on May 1st, 2018.  The announcement says they can't start until August 1st at 12 AM.

278588_Screenshot (15).png

Highlighted

Hi Jeff -

Kona is talking about the assignment itself.  Check the dates on it for available, due and until dates.

Ron

I reread your comment, and from that comment it sounds like the course has not been published (I know that is very basic, but I have made that mistake myself - published and set up all the material for the course and forgot to publish it)

Highlighted

jmaclean@tvusd.k12.ca.us, you might want to check the section dates. You should be able to see this by going to your course settings and clicking on "Sections." Click on the name of a section and then click "Edit Section." Check these dates to make sure there isn't a conflict with your regular course setting dates.  

View solution in original post

Highlighted

In my mastery connect I cant submit assignment and it just says saving and it won't submit

Highlighted
Surveyor

Kona, you got it!!!!

Thank you so much.  My one section was set to start on July 1st even though the class was to start May 31st.  That kept my students from starting their summer assignment.  That might not be a bad thing in the long run, but I wanted to at least show them how to submit their assignment before they left for the summer.

Thank you everyone for all your help.