cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Surveyor

fixnum deprecated on canvaslms installation

Hello am facing some error through the installation of canvaslms and blocked on the command `bundle exec rails db:initial_setup` and give fixnum deprecated
This this the trace:


> /var/lib/gems/2.4.0/gems/soap4r-ruby1.9-2.0.5/lib/soap/mapping/encodedregistry.rb:150: warning: constant ::Fixnum is deprecated
/var/lib/gems/2.4.0/gems/soap4r-ruby1.9-2.0.5/lib/soap/mapping/encodedregistry.rb:216: warning: constant ::Fixnum is deprecated
rails aborted!
Don't know how to build task 'db:initial_setup' (See the list of available tasks with `rails --tasks`)
/var/lib/gems/2.4.0/gems/railties-5.2.4.3/lib/rails/commands/rake/rake_command.rb:23:in `block in perform'
/var/lib/gems/2.4.0/gems/railties-5.2.4.3/lib/rails/commands/rake/rake_command.rb:20:in `perform'
/var/lib/gems/2.4.0/gems/railties-5.2.4.3/lib/rails/command.rb:48:in `invoke'
/var/lib/gems/2.4.0/gems/railties-5.2.4.3/lib/rails/commands.rb:18:in `<top (required)>'
/home/badr/canvas/bin/rails:9:in `require'
/home/badr/canvas/bin/rails:9:in `<top (required)>'
/var/lib/gems/2.4.0/gems/spring-2.1.0/lib/spring/client/rails.rb:28:in `load'
/var/lib/gems/2.4.0/gems/spring-2.1.0/lib/spring/client/rails.rb:28:in `call'
/var/lib/gems/2.4.0/gems/spring-2.1.0/lib/spring/client/command.rb:7:in `call'
/var/lib/gems/2.4.0/gems/spring-2.1.0/lib/spring/client.rb:30:in `run'
/var/lib/gems/2.4.0/gems/spring-2.1.0/bin/spring:49:in `<top (required)>'
/var/lib/gems/2.4.0/gems/spring-2.1.0/lib/spring/binstub.rb:11:in `load'
/var/lib/gems/2.4.0/gems/spring-2.1.0/lib/spring/binstub.rb:11:in `<top (required)>'
/home/badr/canvas/bin/spring:13:in `require'
/home/badr/canvas/bin/spring:13:in `<top (required)>'
bin/rails:3:in `load'
bin/rails:3:in `<main>'
(See full trace by running task with --trace)

Tags (2)
0 Kudos
0 Replies