cancel
Showing results for 
Search instead for 
Did you mean: 
ljoaquim
Surveyor

"Access Denied"

Jump to solution

We are facing some big issues in showing HTML contents, all published in courses file manager, to a lot of canvas users. When they click on the module item that calls the HTML file, an "Access Denied. You don't have access to view this page" message shows up and the HTML interface don't load, this happens basically on Google Chrome.

Our big problem, is that this behavior is happening for some users but not for others with same roles in the same course. We tried to force the problem (or the solution) cleaning cookies, renewing IPs, testing on different computers etc, but nothing works. Who already have the denied access to the files still keeps it and that ones that are not facing the problem still can view normally the HTML files, but, sometimes these last ones starts to have the same denied access.

The HTML files are developed in valid HTML5, using external CDN (StackPath account), with secure protocol, to storage the .js and .css files that will set the interface.

Sometime ago we use to have some rare reports about this problem, that we've never been able to reproduce, but now theres a LOT of users reporting these blocked access behavior.

We don't know if this problem have some to do with the recent Google Chrome cookies 'same-site' changes, or another policies changes.

We kindly hope that someone can help us urgently S.O.S Smiley Happy

Greetings,

Luciano

1 Solution

Accepted Solutions

Hi Renee!

I found a solution to the issue with HTML showing files. It´s just a Chrome samesite cookies configuration on the user browser:

  1. On the chrome url bar, digit "chrome://flags" and press "Enter"
  2. In the search bar of the page that opens, search for the "SameSite by default cookies" item.
  3. Change the item status to "Disabled".
  4. In the bottom of the page click on the "Relaunch" button,
  5. The browser will reload an the problem is solved!

Thanks!

View solution in original post

2 Replies
Renee_Carney
Community Team
Community Team

 @ljoaquim 

Sorry someone hasn't jumped in to help you out yet.  Were you able to develop a solution for this problem?  Or reproduce it for that matter?

Hi Renee!

I found a solution to the issue with HTML showing files. It´s just a Chrome samesite cookies configuration on the user browser:

  1. On the chrome url bar, digit "chrome://flags" and press "Enter"
  2. In the search bar of the page that opens, search for the "SameSite by default cookies" item.
  3. Change the item status to "Disabled".
  4. In the bottom of the page click on the "Relaunch" button,
  5. The browser will reload an the problem is solved!

Thanks!

View solution in original post