Community

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Jeff_F
Community Champion

Broken public iframe embeds and iframe load test?

When we transitioned to Studio we specified that we were to use the LTI embed code and not the public iframe embed html option.   We made that decision, in part, as we wanted the instructors to have access to the Studio analytics that come with the LTI embed.  The public embed code does not give such analytics.

Looking ahead, does anyone know of a resource similar to the course link validation tool that will check pages and report back if embedded iframes do not fully load?   This may help with Studio embeds but also perhaps other content sources as well.

This idea came to light this week when we received a report of a few videos that used the public embed not loading.  To review the scope, I crafted a Canvas Data report that searched for the presence of part of the public embed code in all the wiki pages, assignments, etc..  Something like this ' allowfullscreen="true" src="https: abcd//.instructuremedia.com/emb  ' .

I then exported the links to the wiki pages, etc., that contain at least one public embed and used a bulk link opener ( https://www.orangefox.com/open/ ) to quickly open 20-30 of these pages at a time so we could visually inspect to see where the Studio media is not loading.  We've checked about 700 so far and found 275 broken embeds.  And we have another 1,000 additional separate links to check.  I am saving that for next week. ;o)

 

ps. On a side note, it is so very odd for so many public Studio embeds to stop working all of a sudden.  I reported this to Canvas support via case #07369954.

 

Labels (3)
0 Kudos
Reply
0 Replies