piyush kukkar

redis is not enabled for this install for oauth

Discussion created by piyush kukkar on Apr 27, 2016
Latest reply on Aug 20, 2016 by s.burugu@elsevier.com

Hi,

 

I am working on integrating an external tool with canvas.

I need to use some APIs for user specific information, for that I ll have to have the oauth2 framework in place. While working on this I am facing this issue. I have given a redirect_uri to a django call in my local. instead of going to that method, its giving a page error. I tried looking into the development.log file where I found an error "redis is not enabled for this install for oauth".

I installed redis . but still the error is present. I have pasted the log here.

 

- application/xhtml+xml

HTTP_ACCEPT: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8

HTTP_ACCEPT_ENCODING: gzip, deflate

HTTP_HOST: localhost:3000

HTTP_REFERER: https://localhost:3000/login/oauth2/confirm

HTTP_USER_AGENT: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36

PATH_INFO: /login/oauth2/accept

QUERY_STRING: "?"

REQUEST_METHOD: POST

REQUEST_PATH: /login/oauth2/accept

REQUEST_URI: https://localhost:3000/login/oauth2/accept

SERVER_NAME: localhost

SERVER_PORT: "3000"

SERVER_PROTOCOL: HTTP/1.1

REMOTE_ADDR: 127.0.0.1

path_parameters: "{:controller=>\"oauth2_provider\", :action=>\"accept\"}"

query_parameters: "{}"

request_parameters: "{\"utf8\"=>\"\xE2\x9C\x93\", \"authenticity_token\"=>\"1DlXgNHhZ3P27cHotCiMDB4DE/7nx1Ho3pZdEOt+GVvhDQfxlrEWF8fG94n+av5je3lpm470OKeKxxhnryRTPg==\"}"

exception_message: Redis is not enabled for this install

hostname: piyush-VirtualBox

pid: 6684

', 'piyush.kukkar@acelearningco.com', 'Redis is not enabled for this install', '17980cae-5202-47a6-8f3d-e78fbf5d4167', 'post', '2016-04-27 12:45:46.454794', 'Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36', 1) RETURNING "id"  [development:1 master]

 

 

I am seeing this error when I click on authorize on the popup.

I suspect something missing in redis.conf

 

any clue guys?

 

Thanks in advance

Outcomes