John Martin

When Roll Call cannot be enabled... (a potential solution)

Discussion created by John Martin on Sep 29, 2016
Latest reply on Feb 22, 2018 by Stefanie Sanders


I had an issue where Roll Call appeared to be broken. I had an instructor who wanted to use it but couldn't get it to activate. I noted it was a UW supported LTI app here ( that claims "By default, Attendance is included in Canvas as a non-submission graded assignment worth 100 points. The display grade is set as a percentage." This appeared to be untrue in my course. There is no Assignment for Attendance by default.


Inline image 1I dug deeper, and went to the "Attendance" link in the Canvas menu. It appeared my browser was blocking cookies. So, as suggested, I tried launching the tool in a new window. A new window launched and the Panda unicycled on it for the 5 minutes I waited. I checked back under Assignments. Still no new attendance assignment...


Here's a screencast of what I did:


It turned out that I was enrolled in my course both as an Instructor and as a Student, and the two roles were competing to access Roll Call, which apparently confused the poor Unicycling Panda. I could not, however, "Delete" the Student Me —

However, I could "Conclude" myself, then refresh, and I was gone. And Attendance started to work for me as expected.