I am having problems completing a production install of Canvas.
This is my third go-around. Usually the hangup is with the version of ruby mismatching the version asked for in Gemfiles.
But this time, I have a more basic unmet dependencies problem early in the instructions, something that has not happened before, even though I have reinstalled Ubuntu 14.04 (the only OS/version I can find official Instructure instructions for) three times.
For this step:
sudo apt-get install ruby2.4 ruby2.4-dev zlib1g-dev libxml2-dev \ libsqlite3-dev postgresql libpq-dev \ libxmlsec1-dev curl make g++
I get this output:
Reading package lists... Done
Building dependency tree
Reading state information... Done
make is already the newest version.
make set to manually installed.
curl is already the newest version.
curl set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
g++ : Depends: g++-4.8 (>= 4.8.2-5~) but it is not going to be installed
libpq-dev : Depends: libpq5 (= 9.3.4-1) but 9.3.17-0ubuntu0.14.04 is to be installed
Depends: libssl-dev but it is not going to be installed
Depends: krb5-multidev but it is not going to be installed
Depends: comerr-dev but it is not going to be installed
libsqlite3-dev : Depends: libsqlite3-0 (= 3.8.2-1ubuntu2) but 3.8.2-1ubuntu2.1 is to be installed
libxml2-dev : Depends: libxml2 (= 2.9.1+dfsg1-3ubuntu4) but 2.9.1+dfsg1-3ubuntu4.8 is to be installed
libxmlsec1-dev : Depends: libssl-dev (>= 0.9.8) but it is not going to be installed
Depends: libgnutls-dev (>= 1.0.0) but it is not going to be installed
Depends: libnss3-dev but it is not going to be installed
Depends: libgcrypt11-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
I could work my way through the whole list, resolving dependencies by manually up- or downgrading to the specific versions mentioned, but frankly I do not have forever to work on this.
It seems like I missed an important step, as this was not a problem in prior (admittedly, failed) installs.
Does this look familiar to anyone?
Where is the document of the most up to date method for production install, or is this really it:
There *must* be better instructions somewhere.
Thanks for any help.