AnsweredAssumed Answered

Help with Rich Content Editor stripping code

Question asked by Sara Davick on Jun 23, 2017
Latest reply on Sep 14, 2017 by Sara Davick

Something new has been happening when I try to embed a video. Always before I was able to simply copy the html code and paste it into the html editor. When I returned to the rich content editor I could continue adding content to my assignment without a problem.

 

Lately, when I embed a video the code that tells the size I'd like iframe to be is stripped and it shows up as a very small embedded video in the assignment.

 

I have found that if I paste the code in the html editor and then save the assignment without returning to the rich content editor the sizing will stick. The problem is that if I return to the assignment to make any kind of changes as soon as I open the editor the code is stripped. If I want to keep the sizing I can not return to make any changes.

 

Any suggestions as to why this is happening now when it wasn't before?

 

This is the html I am pasting: <iframe width="853" height="480" src="https://www.youtube-nocookie.com/embed/dAgfnK528RA?rel=0" frameborder="0" allowfullscreen></iframe>

 

This is what it looks like when the editor strips it: <iframe src="https://www.youtube-nocookie.com/embed/dAgfnK528RA?rel=0" allowfullscreen="allowfullscreen"></iframe>

 

The video shows up like this:

 

Here is what I'd like it to look like:

 

 

Edited to add:

 

I just discovered the ALT + F9 option that opens the hidden menu allowing another way to insert embedded video from the rich content editor without using the html editor. Using this method also results in stripping the size of the video.

Outcomes