Clint Jacobsen

Issues with Flash and Recording Video with the RCE Media Tool

Discussion created by Clint Jacobsen on Jun 28, 2017

We are noticing an issue with what may be something stemming from a bug to a recent Adobe Flash release: recording & embedding video through the RCE media tool cannot happen w/ editing flash preference settings to immediately ‘allow’ the use of a computer’s camera and microphone instead of ‘ask[ing] me’.  The images below may help illustrate, as may the video linked to here.  This is problematic for security reasons, our IT team is telling me and won’t/can’t be deployed on our networked computers, and will be difficulty to accommodate/inform our campus users using their own computers/devices.

 

Has anyone else run into or heard about this/is this issue.  It only recently seems to have started to occur. Initially this was reported by one of our instructors using FireFox but we are seeing the issue across all browsers… I checked in with tier I support and they came back with…

 

“I was unable to recreate your exact issue, and based on the screencast provided, it looked like the problem was with Flash accessing your camera. That is outside of Canvas at that point, so we are not able to provide support for that program. I suggested making sure Flash was up to date and that the browser is not blocking it from accesses the accessories.”

 

… which is an answer… but, like I led to before, only presents some problematic work around’s and workflows.

 

MacOS

 

 

--

Windows 10

 

Outcomes