AnsweredAssumed Answered

do_course_copy.py and API

Question asked by Dave Dieckmeyer on Oct 25, 2017
Latest reply on Dec 7, 2017 by Dave Dieckmeyer

Hi everyone,

For the last two semesters we've used the do_course_copy.py script in the GitHub Unsupported canvas pages to apply a template course to other courses, with great success. I tried to use it for the up-coming semester, which starts in January, but am getting errors now. My error is a KeyError generated by line #38. It doesn't like the "_copy[destination_column_name])".

 

I noticed that in the "course_copy" API there is a note that it says "DEPRECATED: Please use the Content Migrations API. So I went there but am now confused about how to get the template ("source" in the previous code) to apply to the course ("destination" in the previous code).

 

If anyone has a better method, or a fix, I am open to hearing from you.

 

Thanks,

Dave

Outcomes