AnsweredAssumed Answered

Is LTI always using oauth version 1.0?

Question asked by Zbynek Dusatko on Mar 19, 2018
Latest reply on Mar 20, 2018 by Zbynek Dusatko

Hello, 
I was following this LTI tutorial
Introduction to LTI Apps: Canvas Dev and Friends 
and at the same time was reading about canvas oauth 2.0 at
OAuth2 - Canvas LMS REST API Documentation 

It seems that Canvas is doing all oauth flow in background for its already installed LTI and it is up to the LTI tool to verify timestamp and auth signature, and so on. But why am I always getting "oauth_version": "1.0"?
Shouldn't there be an option to use oauth 2.0? Is it in XML configuration? Couldn't find it.
Thanks for any advice,
Zbynek

Outcomes