AnsweredAssumed Answered

Disable the course navigation by default in LTI 2

Question asked by Ahmad Hassan on Mar 21, 2018
Latest reply on Aug 4, 2018 by James Jones

Hi,

 

I am creating an LTI-2 app and i am using ims-lti Gem.

I am able to launch the app but the problem is that it is enabled for all courses. 

By default, course navigation should be disabled and the teacher should explicitly enable it.


I know there is an API to update the apps

api/v1/accounts/{id}/external_tools/{id}

 

But the issue is that I don't see the app which I launched using LTI-2 however, I am getting those apps which i am launching using this API

 

curl -X POST '{host}/api/v1/accounts/1/external_tools' \
-H "Authorization: Bearer {Tocken]" \
-F 'name=LTI Example' \
-F 'consumer_key=asdfg' \
-F 'shared_secret=lkjh' \
-F 'url=https://example.com/ims/lti' \
-F 'privacy_level=name_only' \
-F 'course_navigation[default]=disabled' \
-F 'course_navigation[text]=LTI Test' \
-F 'course_navigation[enabled]=true' \
-F 'user_navigation[visibility]=public'

 

I thought i am doing something wrong but i tested lti_tool_provider_example app as it is and this app is also not coming is external_tools list API.


Is it expected behavior of LTI 2 or is there a different API for LTI 2?
Is there a method or parameter that I can use to disable the course navigation by default?

 

GitHub - instructure/lti_tool_provider_example: This is a basic and simple LTI Tool Provider that uses the [ims-lti](htt… 

Outcomes