Hans Magnus Mikalsen Nedreberg

Using the iOS Apps and Frameworks from Github

Discussion created by Hans Magnus Mikalsen Nedreberg on Apr 27, 2018
Latest reply on May 19, 2018 by Ryan.Seilhamer@ucf.edu

When trying to set up the Xcode project provided on Github, I get 22 warnings and 3 errors. The errors are all related to the Podfile.

When running pod install I get:

[!] No podspec found for `BVLinearGradient` in `./rn/Teacher/node_modules/react-native-linear-gradient`

However, there is no folder named "node_modules" in the "Teacher" folder.

 

It's described as a dependency in the Podfile file on line 153:
DEPENDENCIES:
- AFNetworking (~> 3.0)
- BVLinearGradient (from `./rn/Teacher/node_modules/react-native-linear-gradient`)

 

Any advice?

Outcomes