AnsweredAssumed Answered

Can't install Canvas Commons on self hosted opensource deployment

Question asked by J Collins on May 3, 2018
Latest reply on Oct 22, 2018 by rogrant@nmsu.edu

This is an issue I have been going around in circles over for the past 8 months. I am currently attempting to install Canvas Commons in a Self-Hosted environment using the opensource deployment from github. I am using the instructions from the  "Instructure Self Hosted Canvas Commons Setup" (this document is out of date). The problem I have is when I attempt to configure the Commons Setup App, I receive  "502 Bad Gateway" error after authorizing the app to access my account.

 

Steps Take to Install:

  • Created Developer Key 
  • Make sure LOR External Tool is on in Settings > Feature Options
  • Add App
  • Configure App from pulldown
    • Copy ID and Key created earlier into Client ID and Client Secret (key)
    • Authorize Commons Key to my account

  • .

I then get a 502 Bad Gateway error.

Is anyone else getting this? I have tried searching and have seen a couple of people have gotten the same error, but no one has responded with an answer on how to get past this.

 

What are some suggested steps to figure this out?

Outcomes