AnsweredAssumed Answered

Browser does not meet minimum requirements

Question asked by Marie Owen on Aug 26, 2015
Latest reply on Aug 26, 2015 by chofer@morainepark.edu

I am using firefox and get a message that says "browser does not meet minimum requirements". How do I fix this?

Outcomes