Community Participant

Canvas quiz not copying correctly to another course

I recently had to modify a canvas "quiz" (really it's a midterm unit exam with lots of questions) I had previously created for three different sections (classic quizzes). I made the needed changes in my template section and saved it. I then attempted to copy it to my other two sections of the same course (listed on canvas as separate courses), but even though it appears on the quiz list under the new, changed name the actual quiz content does not reflect the change. It appears that some of the old questions that were deleted in the revision that I copied over are still present in the "copied" version on the other sites. I've no idea why.


The workaround will probably be to simply delete the old quiz completely from the other two sites and to re-copy the modified version, but it doesn't make sense that I would have to do this since I changed the name of the modified quiz version. I did want to keep the old quiz versions (unpublished) as possible make up exams or for a future semester.

This is now impossible anyway, as even though I changed the name of the revision I copied over, it appears to have replaced the original quiz file it was replacing anyway. The original version of this file is no longer visible after I copied the modified version over.

The first screen shot shows the version I had fully modified and copied over on the first of my canvas sections, while the second shows what that copied file looks like on one of my other class sites.

Is this a bug or an odd feature masquerading as a bug?

Labels (1)
Tags (1)
0 Kudos
8 Replies
Community Contributor

@erica_wagner Ugh, it's a bug! We've run into this at our institution, too. For some reason, Canvas doesn't see assign the copy a new assignment ID, so it overwrites the existing quiz instead of creating a new copy. It sounds like you've already tried what we suggest to our faculty (I'll copy/paste that below), but you might try a more substantial name change on the quiz. This is definitely something Canvas Support should be aware of (and fix), so please put in a ticket with them if you haven't already!


Here's the instructions that we've given our faculty:

Faculty may experience a bug when copying New Quizzes. When copying a New Quiz, several faculty have experienced issues where Canvas restores an older version instead of copying the current version.
If you are experiencing this Canvas bug, there are two ways to troubleshoot: making a substantial change to the name of your quiz or copying the quiz to another course and back to the current course.

Substantial Name Change

  1. Select Quizzes from the course navigation.
  2. Locate the quiz, select the three-dot menu, and select Edit.
  3. In the name field at the top of the quiz setup page, make a substantial change to the quiz name.
  4. Select Save.
  5. Locate the quiz, select the three-dot menu, and select Duplicate.
  6. Click on the duplicate and select Build.
  7. Verify the quiz is the most current copy.

Copying Out to Another Course & Back

  1. Select Quizzes from the course navigation.
  2. Locate the quiz, select the three-dot menu, and select Copy To.
  3. From the dropdown, select a course into which you will copy this quiz. (A sandbox course is recommended.)
  4. Select Copy.
  5. Navigate to the second course (the course you selected in step 3).
  6. Repeat steps 1-4, this time copying the quiz back into the original course.
  7. Navigate to the first course and verify the copy is the most current version.

Note that you may combine the two methods above (copy the quiz to a second course, make a substantial name change, and copy it back) to ensure Canvas sees they copy as a new assignment ID.
0 Kudos
Community Participant

@kona do you know if this is a known issue the programmers are working to solve.

0 Kudos

@cunninghama - greetings! Unfortunately, I don't know if this is being worked on or not. I don't work for Instructure so I don't have this type of insider knowledge. My recommendation would be to reach out to your Canvas CSM (or the Canvas Admin at your school if you don't know who your CSM is) to see if they can find out this information. 

Good luck! Kona

New Member

Thank you!
I struggled with this all semester and this trick worked, I made a copy of the updated one with a new name and was able to copy it to the second section successfully.

This is a strange bug that needs fixing but thank you for saving me from having to update final exams by hand!

0 Kudos
New Member

After a lengthy conversation with Canvas support, we arrived at this solution:

  1. Select the quiz you want to copy from the original course
  2. Select the 3 dots on the right then duplicate
    1. The new/duplicated quiz will have the word “copy” at the end of the title
    2. You may want to delete the original quiz
  3. Copy the duplicate quiz into the desired course

FYI: Duplicating the quiz gives it a new Canvas ID number.

Thank you for sharing this workaround! It is such a frustrating issue, especially when working with multiple sections of the same course.
0 Kudos
Community Participant


0 Kudos
New Member

These workarounds do not work, nor does starting with the course you would like to copy to, importing content, choosing quizzes.  I got an error message for only this renamed quiz.  I will have to rebuild it from scratch in the new course.

0 Kudos