SIS Import: "No short_name given for course"

Community Champion

This is more of a "heads up" than a discussion, and it didn't fit as a question either.

I was attempting to create a few courses via the GUI "SIS Import."  My courses.csv file had the structure shown below.


I clicked on Choose File and selected the above file.  Chose "Instructure formatted CSV..." for the file format and clicked on the Process Data button.  The process started, and almost immediately failed, giving an error like that shown below:


"No short_name given for course," I said to myself, "Yes, it's right there!  There's a short_name for each of the courses!"

*By the way, the blurred out short names were each valid.  I tried again, and failed again.

I looked at the "courses.csv" format online, and saw nothing wrong.  I even downloaded the example courses.csv file and compared it to my courses file.  The example file ran without a problem, but my file continued to fail.

Finally, I am moving my cursor between field names in my courses.csv file, and my eye catches a slight difference.  The "short_name" field actually had a space in front of it, so it was " short_name".  I removed the space in front of this field, and saw there were a couple of other column IDs that had leading spaces and removed those spaces.  I re-saved the file.

I ran the SIS Import which now completed successfully;-)

Labels (1)