cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
obinna
Community Member

Self-Hosted Canvas Commons Setup Error

I'm trying to setup a self-hosted Canvas Commons using this document https://community.canvaslms.com/docs/DOC-4473 but I get this error

Sorry, there is a problem in your Canvas/Commons configuration.

The Canvas launch of Commons does not contain the required information.

code: INVALID_LAUNCH

Please notify your Canvas administrator.

Anyone know how to resolve this?

Tags (1)
0 Kudos
3 Replies
Robbie_Grant
Community Coach
Community Coach

obinna,

We are giving the Canvas Admins area a little bit of love (especially questions that are really, really old) and just want to check in with you.  This will also bring this question new attention. 

 

Were you able to find an answer to your question? I am going to go ahead and mark this question as answered because there hasn't been any more activity in a while so I assume that you have the information that you need. If you still have a question about this or if you have information that you would like to share with the community, by all means, please do come back and leave a comment.  Also, if this question has been answered by one of the previous replies, please feel free to mark that answer as correct.

 

Robbie

marcmercado1993
Community Member

I am having the exact same problem. I had Commons working a 2 days ago, however I don't think that https://lor.instructure.com/api/lti/self-hosted-setup is working any more.

gmorris1
Community Participant

I am having a slightly different issue. I get all the way to the last step, and when I click Authorize, I receive this error message: 

Incomplete response received from application