cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
roperera
Community Member

Canvas API Access Tokens are not Working

I am using Bitnami Amazon Machine Image of Canvas LMS and tried to access my Canvas LMS with API access token. Tried with the following API route but failed. Can Some one help me with this..??

I have generated the token as shown in the below image.

I have used the below route;

curl -H "Authorization: Bearer Y21N9JimVg4OOtGUc0RHjNKzXXd19f5KRjhZJAmdGDZmL2Td9izFjtkZvHHkbDlU" "http://localhost:8082/api/v1/courses"

 

Output: {"errors":[{"message":"Invalid access token."}]}

Is there any Configuration Changes needed to be done or else any other setting needed to be changed in order to access this..??

 
Labels (5)
0 Kudos
2 Replies
matthew_buckett
Community Contributor

Have you configured redis to work with your Canvas instance? Most parts will work without it but I believe you need to enable redis to have tokens working.

roperera
Community Member

@matthew_buckett  Thank you for the reply.

My redis.yml config file looks like;

production:
servers:
- redis://127.0.0.1:6379

and Port ;

tcp 0 0 127.0.0.1:6379 0.0.0.0:* LISTEN 28831/redis-server

So I believe that redis is working fine;

Is there any other way to confirm this..?? 

Is there any other config available to set up token configs..??