cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jarredtruschke1
Community Participant

This tool has already been installed in this context. Would you like to install it anyway?

Jump to solution

Hi everybody,

I'm really hoping some kind soul can help me out here. I'm learning LTI development for a few different projects we have in the pipeline. I have a Hello World app that I'm learning with.

I understand the XML, URL, and Manual Entry methods. I understand programming. I have an XML file that I've generated with the correct information. I'm stuck on what seems like the simplest thing though...

When I try to install a new application on a sandbox course, I get the error message "This tool has already been installed in this context. Would you like to install it anyway?" With 2 options, "No, Cancel Installation" and "Yes, Install Tool". I get the same error message whether I copy and paste the XML, point to the XML, or even just add an app manually with only the Name, Consumer Key, Shared Secret, and Launch URL fields.

I don't see how this tool could have been installed previously. It's a sandbox course on our main instance. The application Name, Consumer Key, Shared Secret and Launch URL are all very unique. I've made sure of it by appending my name and the date. I've also tried some really out there configurations. I still get the same message.

Can anybody talk me through this? I'm not installing the app, just in case I end up overwriting something else that is going on in the background that I'm unaware of. I've searched everywhere for an answer to this question, but I seem to be the only one with it on the entire internet, lol!

Thanks so much!

-Jarred

Labels (1)
0 Kudos
1 Solution

I suspect it is the domain of the launch URL which is causing Canvas to think the tool is already installed.  Do you have any other tools defined on the same server?

View solution in original post

4 Replies
themidiman
Community Champion

Just curious: Has the app been installed at the parent account in which the sandbox course resides?

0 Kudos
jarredtruschke1
Community Participant

No, it hasn't. This is definitely an app that has unique name made up of my name, date, and time. 

0 Kudos

I suspect it is the domain of the launch URL which is causing Canvas to think the tool is already installed.  Do you have any other tools defined on the same server?

jarredtruschke1
Community Participant

@svickers2 That's exactly what it was! We're developing a few LTIs and serving them from the same domain. The message appears to be more informational than an actual error message.

Thanks! 

0 Kudos