cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sue_winter
Community Participant

Problems Using FlipGrid in Canvas

Jump to solution

I have added the FlipGrip App to my Canvas course, but when I click on FlipGrid in the menu on the left or select it as an External Tool in an assignment, I just get an LTI Launch Error (see below). Other external apps, such as EdPuzzle, work fine. Note, I am not in student view even though the message says Please contact your instructor.

Just to complicate things, I added the FlipGrid app twice. After adding it once, I was not able to see it in external tools or in the left menu. After adding the app the second time, it showed up twice in both placed. I also don't now how to uninstall or remove one of the FlipGrid instances.

Has anyone else run into any of these problems or does anyone have a suggestion to troubleshoot them?

Thank you!

340274_pastedImage_1.jpg

28 Replies
sue_winter
Community Participant

I just started teaching a new course, so I decided to try to add Flipgrid to a fresh course. The only thing I did differently this time was to go into View App Configuration and click on the cog beside Flipgrid. There wasn't anything to change, so I just cancelled out. But it seems to be working this time! It is still not working in my sandbox course where I had the original problems, but I won't worry about that for now.

I have the cog beside Flipgrid in my new course in View App Configuration. Should I worry that there is something that I haven't done yet to finish the setup? I assumed that once all of the configuration was complete, I would see 'i' like the other apps.

Thank you for your help!

chofer
Community Coach
Community Coach

Hello  @dreed2 ...

Yes, it is possible that other LTI apps would include the "Assignment Selection" placement.  However, generally speaking, it's been my experience when integrating LTI external tools that we (as end users) are not the ones who ultimately get to decide where those placements occur in Canvas.  I believe that's usually a decision made by the makers of the LTI integration...such as Flipgrid.  There may be ways to configure the app to be placed in other areas of the course manually, but I would then be curious if the makers of the LTI integration really intended for it to be in that placement if it wasn't there as a "default".  So, I guess what I am saying is that I doubt you'll be able to ever see "Assignment Selection" as a placement in that pop-up box.  However, and this is the strange part, the information on this page, EduAppCenter: Flipgrid, says that you can use Flipgrid in an assignment as an external tool...even though it's not showing as an "Assignment Selection" placement.  (Strange, right?  Maybe they just missed adding that when they were building the integration?)  I just tested adding Flipgrid to an assignment as an external tool, and it works as expected.

I did want to make one slight amendment to something I wrote the other day about the "i" icon.  I found something in this Guide, How do I use the Canvas App Center in a course?, that confirms my thinking.  If you look at the section near the bottom called "View Account-Level Apps", it says, "Apps that have been configured by your Canvas admin at the account level display a Lock icon [1]."  And, the next section on "Manage Course-Level Apps" shows a screen shot with apps that do not have the lock icon.  Those apps have been added at the course level, not the account level.  So, even though I was referring to the "i" icon in my previous response, I should have been referring to the "Lock" icon just to the left of the "i" icons.  The rest of my reply still holds true, though.

I hope this extra bit of information is helpful to you, Danielle.

Hi  @sue_winter ...

I am not sure if you've had a chance to read through the below conversation that  @dreed2  and I have been having, but I would encourage you to read through it...as I have been explaining when you would see the cog wheel vs. when you would see the "i" icon.

dreed2
Community Member

Yes that makes sense - I think because in the other apps, I can navigate the app when I am linking it as an external tool but with Flipgrid, I don't have that option.  Now that I've played with it for a while, I have a much better sense of how the whole process works.  Thanks so much for all of your help and the links as well.  It was a lifesaver and now I look like a rockstar to my 5th graders Smiley Happy

sue_winter
Community Participant

 @chofer 

Thanks Chris, I have gone back and read your comments, and they were indeed helpful! I really appreciate your support!

sue_winter
Community Participant

 @chofer ‌

Thank you. I referred back to your comments and the 'i' and the cog, and I am starting to get it. I appreciate your support!

ssundine
Community Member

Thanks for the conversation about the Flipgrid LTI.  I too am having the same issue right now with getting the message LTI Launch Error when I clicked on Flipgrid from my Navigation bar.  I am a Canvas Admin for our school and I am in a teacher's account getting that error.  I can successfully launch the app in one of my courses, but not hers. 

Suggestions?

amythomas1
Community Participant

I am having the same issue. The teachers in my building are not able to see anything under Placement. 

It appears that teachers may need to generate their own key and code and add Flipgrid to their own courses since it is associated with a log in.   Go to Settings > Apps > search Flipgrid.  When you click on install it gives you instructions on creating an account and generating a consumer key and secret code.  So each teacher has to do this at their course level.  Hope that works for you!!!

amythomas1
Community Participant

They have added their own consumer key and secret code the app is not showing up on their homepage.