AnsweredAssumed Answered

Question about environments in LTI configuration

Question asked by J B on Jun 13, 2018
Latest reply on Oct 16, 2018 by J B

Here is the xml configuration I am using:

 

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<blti:title>theTitle</blti:title>
<blti:description>theDescription</blti:description>
<blti:custom name="custom_fields">
<lticm:property name="canvas_account_id">$Canvas.account.id</lticm:property>
<lticm:property name="canvas_account_name">$Canvas.account.name</lticm:property>
<lticm:property name="canvas_account_sis_id">$Canvas.account.sisSourceId</lticm:property>
<lticm:property name="canvas_api_domain">$Canvas.api.domain</lticm:property>
<lticm:property name="canvas_shard_id">$Canvas.shard.id</lticm:property>
<lticm:property name="canvas_membership_roles">$Canvas.membership.roles</lticm:property>
<lticm:property name="canvas_root_account_id">$Canvas.root_account.id</lticm:property>
<lticm:property name="canvas_global_root_account_id">$Canvas.root_account.global_id</lticm:property>
<lticm:property name="canvas_user_id">$Canvas.user.id</lticm:property>
<lticm:property name="canvas_user_login_id">$Canvas.user.loginId</lticm:property>
<lticm:property name="canvas_masquerading_user_id">$Canvas.masqueradingUser.id</lticm:property>
<lticm:property name="canvas_masquerading_user_user_id">$Canvas.masqueradingUser.userId</lticm:property>
<lticm:property name="person_email_primary">$Person.email.primary</lticm:property>
<lticm:property name="person_name_full">$Person.name.full</lticm:property>
<lticm:property name="person_name_full">$Person.name.full</lticm:property>
<lticm:property name="person_sourced_id">$Person.sourcedId</lticm:property>
</blti:custom>
<blti:extensions platform="canvas.instructure.com">
<lticm:property name="tool_id">theToolID</lticm:property>
<lticm:property name="privacy_level">name_only</lticm:property>
<lticm:options name="global_navigation">
<lticm:property name="text">theMenuItemText</lticm:property>
<lticm:property name="url">theLaunchUrl</lticm:property>
<lticm:property name="icon_url">theIconUrl</lticm:property>
<lticm:property name="visibility">admins</lticm:property>
<lticm:property name="enabled">true</lticm:property>
<lticm:property name="oauth_compliant">true</lticm:property>
</lticm:options>
<lticm:options name="environments">
<lticm:property name="launch_url">TheTestLaunchUrl?</lticm:property>
<lticm:property name="domain">TheTestLaunchDomain?</lticm:property>
<lticm:property name="test_launch_url">TheTestLaunchUrl</lticm:property>
<lticm:property name="test_domain">TheTestLaunchDomain</lticm:property>
<lticm:property name="beta_launch_url">TheBetaLaunchUrl</lticm:property>
<lticm:property name="beta_domain">TheBetaDomain</lticm:property>
</lticm:options>
</blti:extensions>
<cartridge_bundle identifierref="BLTI001_Bundle"/>
<cartridge_icon identifierref="BLTI001_Icon"/>
</cartridge_basiclti_link>

 

In regards to the "environments" section of the configuration, it seems like the placement does not work unless the "url" property is set under the global_navigation option. It also seems like something is wrong with the way I am setting up the environments section because it still uses the production launch on the test server. The documentation shows the same url for launch_url and test_launch_url.

 

Question 1: Can someone provide a working example of the environments section?

Question 2: Is the "launch_url" of the environments section supposed to be production or test?

 

 

EDIT:

I think this post confirms that I am close to setting it up correctly. It also suggests that the environments setting is only used when pushing production down to test or beta so that is probably why I am not seeing it work yet.

 

Question 3: Is there a way to force updating test from production or do I have to wait 3 weeks to test this out?

Outcomes