cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sgriffith
Community Contributor

Hiding "Start a New Course" button

Jump to solution

Hi Admins!

Before we switched over to the new UI I didn't have an issue with the "Start a new Course" button appearing. Now it's showing up even though I have the settings set to only Admins can create new courses.

Here are the settings:

177729_pastedImage_0.png

And here is the annoying button:

177730_pastedImage_1.png

Does this sound like a glitch or do I need to ask a java script expert to make it disappear?

Thanks for your help!

1 Solution
sgriffith
Community Contributor

Absolutely,  @kona ! It was an odd scenario that may only apply to colleges who are part of a consortium.  In Washington state all our Community and Technical Colleges are under a State Board.  The State Board has a canvas site and most of our faculty have a login for their college's Canvas site and the State Board Canvas site.  When the faculty member would log in at LCC's canvas site (lcc.instructure.com) it was rerouting her to the state board's site instead (sbctc.instructure.com). It turns out when she uses her state board credentials to log into her LCC account it reroutes her to the state board site instead of telling her she has the wrong username and password. On the state board site they allow faculty access to the "Start a New Course" button. It was especially deceiving because it would show the Lower Columbia College logo in the top left corner, yet have the sbctc.instructure.com URL. I  provided her with a different password for her LCC account to differentiate her LCC account from her SBCTC account just to cover all the bases. I'm still waiting to hear from the instructor to make sure the fix has completely worked. In theory the issue is resolved...I'll update this when I hear from the instructor!

View solution in original post

9 Replies
Robbie_Grant
Community Coach
Community Coach

 @sgriffith ​,

We are not using any type of javascript overrides on our beta instance, we have only Admins allowed to create courses and I just masqueraded as an instructor and do not see the Start a New Course button.

I would recommend contacting Instructure Support from Help > Report a Problem.


Robbie

This is our experience as well, so I second contacting Canvas Support!

sgriffith
Community Contributor

Thanks  @Robbie_Grant ​ and  @kona ​! The issue has been resolved Smiley Happy.

kona
Community Coach
Community Coach

 @sgriffith ​, can I ask what you needed to do to resolve the issue? Just curious in case someone else in the Community has the same problem as you did!

sgriffith
Community Contributor

Absolutely,  @kona ! It was an odd scenario that may only apply to colleges who are part of a consortium.  In Washington state all our Community and Technical Colleges are under a State Board.  The State Board has a canvas site and most of our faculty have a login for their college's Canvas site and the State Board Canvas site.  When the faculty member would log in at LCC's canvas site (lcc.instructure.com) it was rerouting her to the state board's site instead (sbctc.instructure.com). It turns out when she uses her state board credentials to log into her LCC account it reroutes her to the state board site instead of telling her she has the wrong username and password. On the state board site they allow faculty access to the "Start a New Course" button. It was especially deceiving because it would show the Lower Columbia College logo in the top left corner, yet have the sbctc.instructure.com URL. I  provided her with a different password for her LCC account to differentiate her LCC account from her SBCTC account just to cover all the bases. I'm still waiting to hear from the instructor to make sure the fix has completely worked. In theory the issue is resolved...I'll update this when I hear from the instructor!

sgriffith
Community Contributor

The theory is official. Everything is back to normal Smiley Happy.

kona
Community Coach
Community Coach

Sounds like a strange situation and I'm glad you got it resolved!

mbaker
Community Member

Hi Sarah,

Tammy Becker and I are trying to hide the "Start a new course" button on our Edmonds CC instance of Canvas.  Can you provide the code that you used to remove it?

Thanks!

Marti Baker & Tammy Becker

0 Kudos
mbaker
Community Member

It took a while... if anyone has this issue:

Admin --> Settings --> Scroll all the way down... Who Can Create New Course.

Thank you anyway.

Marti & Tammy

0 Kudos