Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Participant

Installing Commons, Error: Incomplete response received from application

This is an issue I have been going around in circles over for the past several days. I am currently attempting to install Canvas Commons in a Self-Hosted environment using the opensource deployment from github. I am using the instructions from the  "Instructure Self Hosted Canvas Commons Setup" (this document is out of date). The problem I have is when I attempt to configure the Commons Setup App, I receive  "Incomplete response received from application" error after authorizing the app to access my account.


Steps Take to Install:

I then get this error. 

Incomplete response received from application

Is anyone else getting this? I have tried searching and have seen a couple of people have gotten the same error, but no one has responded with an answer on how to get past this.


What are some suggested steps to figure this out?

3 Replies
Community Champion

Have you had any luck with your issue?

0 Kudos
New Member

Hey  @9927744 ‌,  @gmorris1 ‌
Could you solve this problem? I have a similar one, no one has answered yet.

0 Kudos
New Member

See the apache error log for details.

Here in my installation: /var/log/apache2/error.log

0 Kudos