Cannot destruct right side of assignment

Jump to solution
Community Explorer

Hi guys,

I have run into this problem. When I try to open my student's mark,

Screen Shot 2022-04-06 at 16.09.31.png

it generates these errors:

Screen Shot 2022-04-06 at 16.10.14.png

Is this caused by my Grapghql? How can I fix it, and why the right side of the assignment cannot be destructed.

Please help, thank you.

Labels (4)
1 Solution
Community Explorer

Hi guys,

This is not related to the custom JS I think (since I have none of custom JS). I guess this is caused by the Analytics plugin with the OpenID settings. 

I'm not the expert in this but what I have tried today is reinstall the whole Canvas (works fine), then install the Analytics plugin (works fine). But after I set the OpenID for authenticating our user, the error appeared.

I have also tried setting OpenID without Analytics plugin installed, it still works fine.

I guess my OpenID setting has something wrong and it affects the Analytics plugin.

My solution is instead of using OpenID, I have used SAML for authenticating my users and magically, it solves my problem. I don't know why it happens but my solution is using SAML.

P/s: after setting OpenID as an authenticating system, it generates the error. Moreover, if I remove OpenID, the error is still there no matter what authenticating system is used. So I have to reinstall the whole new Canvas (with a new Database also, I guess). And do not even think about OpenID 😂.

View solution in original post