Community

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
AsimAziz
New Member

Open source canvas and LTI2 memberships

Does the open source version of can support LTI2 registration workflow with memeberships?

I keep getting the following error:

lti_errormsg:

Sorry, there was an error connecting you to the application.lti_errorlog:
Debug error: Required service(s) not offered - 'application/vnd.ims.lis.v2.membershipcontainer+json' [GET]
0 Kudos
1 Reply
sendres
Community Member

Hi @AsimAziz,

If you are developing an LTI 2 tool, you'll pretty much want to drop everything and switch your approach to LTI 1.3 instead. All LTI versions other than 1.3 are on their way out as this security announcement from IMS Global (now 1EdTech) makes clear.

I believe LTI 2 is no longer supported and Instructure has announced that LTI 1.0.2 and 1.1.2 support will end in 2023. LTI 1.3 is the only path going forward.

0 Kudos