cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MeganLai
New Member

Am I allowed to use Canvas even though my browser does not meet the minimum requirement?

Jump to solution

My laptop is old and as I logged onto Canvas (my first time using it, I'm a student), it told me my browser did not meet the minimum requirements. I tried to update it but my Chrome didn't let me and Safari too. Can I still use Canvas even if my browser (I prefer using Chrome) does not meet the minimum requirements? 

Thank you!

0 Kudos
1 Solution
Chris_Hofer
Community Coach
Community Coach

Hi @MeganLai ...

Instead of updating Chrome via the browser, have you tried downloading a new copy of Chrome (which would be the latest version)?

Google Chrome - Download the Fast, Secure Browser from Google

View solution in original post

3 Replies
ericwhitmer
Community Contributor

Canvas will still work, but there will be broken elements because you are using a highly outdated browser.

0 Kudos
Chris_Hofer
Community Coach
Community Coach

Hi @MeganLai ...

Instead of updating Chrome via the browser, have you tried downloading a new copy of Chrome (which would be the latest version)?

Google Chrome - Download the Fast, Secure Browser from Google

Hello, thank you so much! It worked, thank you so much again for your help!