cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
DJ_Rao
Community Member

Incorrect check for file type when submitting URLs via LTI

I have a custom canvas plug-in that uses LTI to submit URLs. The plug-in has been working great for 2.5 years and has gone through 100,000+ submissions by 100s of students. 

However, since Sept 29 2021 (around 6 PM EST) the submission started failing with the error message -- "Invalid submission file type", even though the assignment settings is to submit "Website URL". Specifically, even though the submission type is "Website URL", it is still calling isValidFileSubmission (in https://github.com/instructure/canvas-lms/blob/master/ui/features/submit_assignment/backbone/Homewor...) which is failing (due to some cached settings with restricting file types). However, that check should never be used because the submission type is "Website URL". This behavior is a bug that started rearing its ugly head since Sept 29 2021 (around 6 PM EST). 

It looks like this is a new bug that has recently rolled out onto Canvas. It must be breaking other LTI's as well. 

I am not sure where to report bugs in Canvas, but I thought I would start here. I will be thankful if someone directs me to the correct forums to reach Canvas developers to fix this issue.

Labels (3)
0 Kudos
1 Reply
chofer
Community Coach
Community Coach

@DJ_Rao ...

I see that this particular question is quite similar to the one that you posted here: New Canvas BUG with Website URL submission via LTI - Instructure Community.  I have provided a couple links for you on how to contact the Canvas Help Desk staff in that posting, so I hope that will be a good resource for you moving forward.  Again, please let us know if you have any questions about this...thanks.