cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
james_ling
Community Participant

Need Help with RCE Server

Running on Ubuntu and running Canvas Instructure but have issues with the RCE server. 

Essentially, when editing a course or a page the right hand Content Selector has the files greyed out and "Loading failed" when you try and expand the links section.

323829_Content Selector.png

I have done some digging and the resolution seems to be to run your own RCE server. After I saw the following on the browser 

323830_Browser Errors.png

I have tried following the instructions and documentation for the RCE server but its not working. I am probably missing something in the dynamic_settings.yml but I cant find a example to follow online.

Does anyone have a working RCE server and an example they can post ?. Even better some more verbose documentation with examples or instructions.

Thank you in advance.@

0 Kudos
2 Replies
Robbie_Grant
Community Coach
Community Coach

 @james_ling ,

First, I want to apologize for your question sitting in the community for so long without a response.

 

Second, it looks like you have stumped the Canvas Community.  Were you able to find an answer to your question? I am going to go ahead and mark this question as answered because there hasn't been any more activity in a while, so I assume that you have the information that you need. If you still have a question about this or if you have information that you would like to share with the community, by all means, please do come back and leave a comment.

How we keep your questions flowing!

Robbie

illiya_ananiev
Community Member

must say that i have been going htorugh the same scenario and not getting anywhere. just reinstaled a development server (off-site) on ubuntu 18.04 as my old server on ububtu 14 needed updating due to errors importing course packages.

anyway it owul dbe much appreciated if a set of instructions for installing (adding) the rce api package was available along with config suggestions for a stand alone developement server (running as a production server i must add).

the instructions provided at https://github.com/instructure/canvas-rce-api/blob/master/README.md really are not enough.

btw i used the starting point https://github.com/instructure/canvas-lms/wiki/Production-Start and found that after many server backups and then restores at almost every step of the instructions that there really is a lacking in "if failed" advice, do this...

the above mentions in brief that the system needs this editor enhancement but doesn't give enough information to complete the addition. that is the step for 'Rich Content Editor'.

After all of the stuffing around i am not at a package that runs in the background listening on port 3001 AND still no access to file menu tab, or ability to pick modules, pages or the like.

i must say that i have had an extremely frustrating adventure working with the install and just want a LOCAL server to develop a critical requirement (ie internal project) for our university.

i would love for someone to show the errors of my ways, but seems that the previous has had some success and not passed the information on.