QTI 2.1 files not able to import into Item Banks, is anyone else having this issue?

Community Member

We are having an issue with importing QTI 2.1 files with linked (or any for that matter) images into item banks in new quizzes.

  • Before 11/9/22 we were able to successfully import QTI 2.1 files into a Canvas Item Bank.
  • Post 11/9/22 we are not able to do this, and have tried to repeat this process with files we previously have been able to make item banks from.
  • The QTI will import, BUT ALL IMAGE LINKS ARE BROKEN, and in some cases the question formats have changed from MC or whatever to all Essay Item Types.
  • NOTE that existing Item Banks created from imported QTI files are NOT affected.
  • This is also starting to occur when we try to Migrate some Classic to New Quizzes (depending on which domain the images are sourced from).

FYI we have already attempted/noticed:


  • Importing from 2 different 3rd party sources of QTI files.
  • Tried exporting a Classic Quiz and importing those QTI's, which has produced the same issue.
  • We have used some QTI files which external image links (to a repository) as well as internal links (images hosted inside our Canvas instance), with the same results.
  • Just in case something has changed, we tried importing a variety of other file type.


  • Working Item Bank image imported from a QTI file- Links out correctly to where the image is hosted.
  • Post 11/9/22 SAME image from an imported QTI file imported and/or migrated NOW has a new path created within our domain before where its sourced from. See example below.

Original file which now does NOT work: https://mychesterfieldschools.quiz-lti-iad-prod.instructure.com/system/lms-exports/v3b6gxyjqtk1/55rx...

Similar file which does work: https://d1pnjt1bpkokz0.cloudfront.net/system/lms-exports/v3b6gxyjqtk1/pm6h6a6j/qti21/image_3.png?t=1...

Notice in the top link, the division name has now been added to the link (bold in red). Again its like Canvas is trying to store it somewhere, and then link out to where it sources from, rather than preserve the original link.

This is very distressing for a large division as we are attempting to build up a large vetted item bank repository, and are currently unable to proceed.

  • Does anyone have any work-arounds for this issue, or know when it will be fixed?