data won't import to gradebook

Jump to solution
Community Participant

Instructor reported issue to be that I was able to verify. Canvas won't upload her large course (800 students) gradebook - won't even recognize changes in CSV file -  even when limit import rows to just 10 students! I am able to make it work in a different course, which happens to be an ORG account, not a credit course account.

Instructor called support and after 45 minutes the support person simply said "don't know"... not a very satisfactory answer.

Anyone else seeing gradebook import issues that seem unexplainable? Suggestions?

Our process:   export the gradebook, leave all 'record" columns and remove unneeded Assignment columns, remove all subtotal and total columns. Enter new data. save as CSV, Import. Doesn't recognize changes in csv file, says "nothing to import". Tried changing grade column name in CSV and re-importing. Same error - which is clearly wrong.


1 Solution
Community Explorer

The solution that was eventually discovered by tech support at my institution: the bug was triggered by the column name containing the word "final". We eliminated that from the name, and the problem disappeared.

View solution in original post