cancel
Showing results for 
Search instead for 
Did you mean: 
srandall3
Surveyor

Weird Canvas Studio video thumbnail problem

OK, this is subtle and weird, so let me try to explain.

What I'm trying to do is upload my lecture Zoom videos into Canvas Studio, link in the captions and then put a thumbnail title page on it that identifies the date and time of the recording.

This works 99% of the time without incident.

But every once in a while, when I go to select the image file to use as the thumbnail, I pick the wrong one. Mistakes happen, no big deal. Just do it again and select the correct one. Right?

Eh, no. Here's an example.

I load the Feb 4 video, but accidently select the "Feb 2" thumbnail, a PNG for image.

Oops. OK, hit "Replace thumbnail" again, select the correct "Feb 4" thumbnail.

"Thumbnail uploaded successfully."

What does it say? "Feb 2". What???

So here's what I've tried to do:

  • Load a completely different image of a dinosaur. It loads and becomes the thumbnail.
  • Now, try to re-load "Feb 4". I get "Feb 2".
  • Change the format of the "Feb 4", and select. I get "Feb 2".
  • Re-draw another completely new version of the "Feb 4" image file, with a different format and name. I get "Feb 2".
  • Load a completely different image of a cat. The cat becomes the thumbnail.
  • Clear all of my browser history, because maybe it's remembering the "Feb 2" in a cookie or something.
  • Try to load ALL of the alternate "Feb 4" image files, one at a time. I get "Feb 2".
  • Load a picture of a spider. I get the spider.
  • Try a different browser on a different computer. Try to load ALL of the alternate "Feb 4" image files, one at a time. I get "Feb 2".

What does Studio think it's doing???

Labels (4)
0 Kudos
3 Replies
chofer
Community Coach
Community Coach

Hello @srandall3 ...

I, too, have experienced similar issues where I wanted to replace the thumbnail image of one of my Studio videos with something else.  However, when I upload a different image, that image doesn't appear to replace the existing one.  I've actually even reported this to Canvas tech support.  The strange thing is that on their end, they were able to see that I had uploaded a new file (they can actually see the filename I used?), but for some reason, I cannot.  When I chatted with tech support (this was before Christmas 2020), I *think* they had me clear our my browser cache (after doing so, close the browser completely) and also re-start my computer.  I *think* that may have fixed things, but I'm not 100% sure.  I may have also tried waiting a day or so to see if the image thumbnail finally decided to update on its own.

You might want to try these things to see if any of them will work for you.  Good luck!  Please keep us posted.  Take care...be well.

@chofer 

Thanks for the suggestions and quick feedback. Nice to know it's not just me.

Unfortunately (or fortunately) I've already been getting into the habit of doing all that "clear clear reboot" with many applications lately, especially browser-based stuff.

As a side commentary ...

Speaking as a former professional programmer and CS trainer, there seems to be an increase in the last decade or so of really sloppy software development. (I'm not pointing at Canvas, per se, but a general trend.) Operating systems like Win10 tend to permit sloppy "roommates" ... you know those people who share your space but never clean up after themselves? In the software version, the code opens resources, or leave breadcrumbs and then doesn't close things down, release devices or clear temporary files very well. Queues get stuck, keys get forgotten, and it's just bad practice all around.

Back to THIS issue ...

When I see stuff like this, my spidey senses tell me that their left hand has forgotten there is a right hand. There's supposed to be some little accounting, double-check, confirmation something something that's not doing it's job or doesn't exist. Not telling people how to do their job, but ... If I were the project manager for this particular patch of software (which I'm not), I'd be running a little process audit on this stretch of code and working to make it more robust.

Suffice to say, it's degrading the delightful customer experience.

Tags (1)
tonyafa
Learner

I too just experienced this issue again.  When I try to upload a "second" thumbnail image to a video it progresses as though it works but doesn't update the thumbnail image.  Clearing cache and cookies, switching browsers, and logging off and back on DO NOT solve the problem either.  When I chatted with Canvas Tech. support yesterday they said it worked fine on their end and we got disconnected without getting the problem resolved.  As both an instructor and a Canvas and Studio Admin. I find this extremely frustrating.